Internet access for client connected to NS

Disclaimer: I’m a complete Linux noob (and therefore a NethServer noob and CentOS noob). I’m not especially computer-savvy (mechanical engineer by education and trade; my computer engineer wife makes fun of me all the time when I try to code), but I can follow directions.

I’ve been following along with CTek’s awesome how-to using physical rather than virtual machines. I was able to install NS on an old desktop that has two physical Ethernet ports. I’ve got eth0 set to green (IP:, Netmask:, no Gateway specified) and eth1 set to red (DHCP rather than static IP; has an IP assigned to it by the Verizon Actiontec Router of First off, here’s my physical setup:

Internet (via Verizon FiOS) ==> Verizon Actiontec Router (IP:; this router acts as my current gateway and firewall) ==(eth1, red) ==> NethServer desktop ==(eth0, green)==> Switch ==> Win8.1 laptop

So here’s the good news:

  1. I’m able to get internet access on my NS machine (I can ping Google, etc., just fine). I’ve updated my NS installation and everything worked just fine.
  2. Using a laptop (running Windows 8.1; IP:, Netmask:, Gateway: unsure what to put here), I’m able to use the WebGUI to access the NS installation.

Here’s my problem: I can’t get any internet access on the laptop. I’m pretty sure this is due to a simple misconfiguration on my part, but I can’t figure out what I’m doing wrong. I’ve tried changing the Gateway on the Win8.1 laptop to both the Verizon Actiontec Router’s IP ( as well as the NS eth0 IP ( I’ve read so many different posts recommendations for the eth0 and eth1 settings that my head’s now swimming (such as the red and green Ethernet ports can’t be on the same network, hence 192.168.2.X for the green network while the Verizon Actiontec Router is At this point, I seem to be just randomly changing settings. Any assistance would be greatly appreciated.

P.S. - Please don’t hesitate to not spoon feed me the answer should the solution be embarrassingly simple. I want to learn the fundamentals so I know what I’m doing and don’t have to resort to hounding the pros. :wink:


First, you can narrow down your subnetmask for Green network to Unless you plan to have more than 254 devices attached on your network.
The gateway for your RED interface is the internal IP address of your Verizon router. If you have RED interface as DHCP client, this should be autoconfigured by DHCP.
The gateway for your client (win 8.1 laptop) is the green NS interface. In your case the Gateway for your laptop is
TIP: configure NethServer as DHCP server on the green interface. Then you don’t have to worry about networksettings on your attached devices. They will be configured through DHCP automagicly. Some devices (like printers) make sense to configure manually.

What you need to check if DNS is configured correctly. If you can access websites through IP address but not through domain name, DNS is your first suspect of error.


Holy smokes, robb…my head’s spinning from that speedy response!! I’m going to give that a go this evening. I hadn’t even considered DNS being the culprit.

Thanks for the assistance, robb! I’ll post back once I’ve updated my those settings.

1 Like

this is correct @robb .

NethServer must use the gateway should be the IP of your router verizon

If you set up a DHCP server NethServer as you will not have to have any problem.

So, your router should only function as such (Modem / Router) without firewall configurations without DHCP or the verizon router only deliver an IP address.

This ip will be assigned to NethServer and should not have any Restricting the router (put as DMZ)

Here in Venezuela there are modem / router and I configured that way. NethServer to be the one to do all the work @FauxAnonymity

1 Like

Thanks for the help, @robb and @jgjimenezs! I followed @robb’s suggestions for the settings and I believe everything is functioning as it should. I’m going to spend some time reading the documentation a little more thoroughly before I come up with any other noob questions. Thanks again for all of the help and explanation, guys! Great community!


It would be truly silly if you don’t ask a question in the first place. Remember, our community has this incredible rule that you can’t ask stupid questions. Only questions not asked are considered stupid. So, please, fire away!