“Instant messaging” module from Software Center not found (NethServer Enterprise 7.9.2009)

I wanted to point out that there is no “Instant messaging” on the available packages, to activate webchat on WebTop 5:

Source link: https://docs.nethserver.org/en/latest/webtop5.html?highlight=chat#chat-integration

how it is solvable?


Thank you community in advance for anyone who has advice or helps; and if it can also be useful to other users.

So you don’t have the community version.
Please, would you simply type “ejabber” into the search box?

Not found ejabber:

It’s called instant messaging:

Maybe try to clean yum cache and update:

yum clean all --enablerepo=*
yum update

Not found:

To workaround the problem, you may install from command line:

yum install nethserver-ejabberd

I guess it’s just an issue with the UI.

Wait. This machine is Enterprise. It seems that the key is not valid or updates are blocked. @Nix do u have a support contract with Nethesis?

1 Like

Test manual installation:

Not found option in WebTop 5 admin panel:

Add (+) ‣ Services ‣ com.sonicle.webtop.core (WebTop) ‣ Resource ‣ WEBCHAT ‣ Action ‣ ACCESS

(source link: https://docs.nethserver.org/en/v7/webtop5.html#chat-integration)

Screen:

(missing function to enable WebTop 5 chat)

The package is not listed in software center as it is already installed (the it usually appears on Applications section).
NethServer Enterprise documentation:
https://nethserver.docs.nethesis.it/en/master/webtop5.html#chat-integration

I have to test the machine for a cooperative company that me trial.

The key is valid:

I also tried that guide,
(https://nethserver.docs.nethesis.it/en/master/webtop5.html#chat-integration),

the problem persists, (unfortunately :frowning: ).

Which webtop5 version do you have?

I discovered the problem:

  1. You need to log into webtop 5 as an administrator user.

  2. Click on: maintenance mode

  3. Do these operations:

Add (+) ‣ Services ‣ com.sonicle.webtop.core (WebTop) ‣ Resource ‣ WEBCHAT ‣ Action ‣ ACCESS

  1. Click pop-up “Save & Close”

  2. Set the maintenance function to off

P.s: Specific:

the package name on enterprise is: ejabberd (Software Center)

–> Problem solved, I hope it can be of help to other users as well.

I thank community for your patience; (I’m new user).

1 Like

Here is the function activated on the user side:

WebTop5 - WebChat Enabled

(message for moderators): is can close the discussion, and put: [SOLVED] ;

Thanks

You’re welcome.

If you have an enterprise I suggest you contact the Nethesis support.
Thank you guys :slight_smile: @dnutan @mrmarkuz

2 Likes