Installing Nethserver in Ubuntu LXD Container

virtualization
v7

(Reggie Ho) #1

NethServer Version: 7.31
Module: your_module

Have anyone successfully installing the NethServer 7.3 in a Ubuntu 16.04 LXD Container ?

I install a CentOS V7 in a LXD container , manually setup Network IP4V tested working OK .

then proceed installing Nethserver 7.3 and reboot the container, but the eth0 now no longer able to grab the IP Address…I assume Nethserver reconfigures the eth0 address, as I cannot use the GUI Dashboard to change the Nethserver Network Setting, How do I reset the IP4V address for the Network Interface manually. The “ifcfg-eth0” file in the “/etc/systconfig/network-scripts/” got deleted after Nethserver 7.3 installation, restoring that file, does not help to reconfigure the eth0 Network settings. Am I missing something… or the Nethserver 7.3 has another Network configuration file stored elsewhere ? Appreciate any comments and assistance. Thnx…

I tried changing the NetworksDB file (/var/lib/nethserver/db/networks using command:

db networks set eth0 ethernet role green ipaddr 192.168.1.7 netmask 255.255.255.0 network 192.168.1.0 onboot yes bootproto static

after reboot eth0 still no working…any other part that I have missed ?


(Reggie Ho) #2

Ok… I finally got it working… need to run

signal-event interface-update


(Giacomo Sanchietti) #3

NethServer inside a LXD container on Ubuntu!? Wow, great achievement! :clap: :clap:


(Reggie Ho) #4

Not quite completely working yet… still have some installation issues…

Having problem installing httpd
Error unpacking rpm package httpd-2.4.6-45.el7.centos.4.x86_64
error: unpacking of archive failed on file /usr/sbin/suexec;59b0443a: cpio: cap_set_file
error: httpd-2.4.6-45.el7.centos.4.x86_64: install failed

although able to start the admin GUI after, slow performance …other issues: not able to do yum update, repository not found etc…

Still trying to figure it out…


(Reggie Ho) #5

Progressing …
Changed Container security privilege : lxc config set [centos7-container] security.privileged true
then able to install all needed files… with network working… able to do yum update and yum install
able to load nethserver GUI interface … some settings not able to configure / Server Name / NTP

Found some service remain failed after loaded…

     smwingsd.service          -- loaded/failed     Server Manager DB cache Daemon ( ??? )
     chronyd.service             -- loaded/failed     NTP client/server  
     systemd-hostnamed.service  -- loaded/failed    Hostname Service
     sssd.service              -- loaded/failed    System Security Services Daemon
     systemd-remount-fs.service   -- loaded/failed    Remount Root and Kernel File Systems 

failed remount-fs/chronyd services may have caused Server Naming Issues…
any comments or idea ???


(André Wismer) #6

@rmk

Hi

I’m trying to set up NethServer in ProxMox (Also Linux Containers).
Running basically into the same issues:

  • Networking (Removed and readded the NIC in ProxMox, configured like you did with

reboot and "signal-event interface-update"
Now networking works.

Quite often - the system seems too slow for the Tasks like reconfiguring. refreshing the browser usually works.
Interesting that as a Container, Nethsever actually sees the HP proliant ML110 G7 underneath. Running as a KVM just shows KVM CPUs…

But performance isn’t really great. Running as a KVM (using much more host resources) but same HW allocation (CPU, RAM) is MUCH faster.

This needs more research!

2 cores (out of 8 incl. Hyperthreading) wasn’t enough… 4 cores really make a speed difference.
4G RAM isn’t plenty, but works on real hardware for a small system. I’m still using 4G RAM in the container, but have the option for more… :wink:

I still get some errors like:

Nethgui:
500 - Internal server error
1366796122+1350909145

if doing things like setting the hostname from the GUI.

This is one of the things still not working yet. The hostname stays empty and only the hostname part - not the FQDN - is displayed in the dashboard.

Updates seem to be working OK.

Andy


(Reggie Ho) #7

Thanks for the infor…It’s been a few weeks ago for me trying to get the NethServer to run in Ubuntu LXD … I have same issues when changing the HostName too - not able to update, and found some other modules will not start.
…keep us posted on your progress…


(André Wismer) #8

@rmk

Hi

actually, the NethServer (Linux Container) was extremly fast in updating and adding in modules - after I added in CPUs and RAM. I’m now using 4CPUs of a Proliant ML110 G7, which has a Quad-Core CPU with Hyperthreading. I’m only using 4GB RAM.

Everything seems to work, as far as you can go without a FQDN Hostname. As far as I can see, it picks up the hostname given by the Container environment. Changing that in NethServer won’t work. Changing the hostname in the CT-Config works. The domain part of the FQDN is ignored in both cases, in CT-Config or in NethServer.
;-(
Also the DNS of the Host is passed thru to NethServer, anything changed in the WebGUI is “added on” to the DNS servers list.

My Container Environment is ProxMox.
I’m using other Centos 7 based Linux Containers - all work well.
But: NethServer is the only one which does funky stuff on the network interface (NIC). Like setting up an AD…
That creates a container (In a container). Sounds to me like long nights or evenings troubleshooting, when something doesn’t work. Also NethServer has built in firewall capabilities…

I intend to use containers for fixed duties, all of which have nothing to do with funky networking, say like a fileserver. Or a LAN proxy server. or monitoring. A centos running FOG-Project handles imaging - and it also runs on a CT…

But at the moment I’m stumped… ;-(

Andy


(NP) #9

did you have any succses with NethServer on proxmoxx LC, i was thinking about the same setup but it looks like a time-consuming thing looking at your results


(André Wismer) #10

Hi

Sry, for the delay in awnsering, but I’m in the process of moving right now, so not all is working as usual… ;-(

I didn’t further pursue that project, as compatibility, say after updates or upgrades would pose further problems, as would using AD, which involves another layer of virtualization…

As you said, too much trouble, even if using a real vanilla centos 7 as starters…
I will look into this further, but for the moment, it rests as is…

My 2 cents

Andy


(NP) #11

I think I’ll try UCS ad and samba in a lcx they also use Debian stretch as
base so Chances look good it’ll work without tinkering, I want to use zfs
on proxmoxx and then bind it into the container


(André Wismer) #12

ZFS is a really great Filesystem, but you need enough RAM for that…

Count at least 8 GB RAM just for the file system - afaik it won’t even start with less.
Better would be 16 or 32 GB RAM for the filesystem.

Most of my ProxMox are only equipped with 16 or 32 GB RAM, so I never bothered on those servers.

Your mileage may vary…

My 2 cents
Andy


(NP) #13

i’ll build a rig with at least 64GB ECC RAM with intel enterprise nvme
drive with 40GB Interconnect to a second rig and synchronizing the zfs or
at least short timed snapshots, maybe even without hard drives and caching,
my plan is to have one zfs disk drive for all file serving where access
times are not really an issue and the nvme for the containers and
performance related stuff, we do not have many servers and databases and i
would like to move away from windows AD so im looking into alternatives,
nethserver looks good but sadly lacking container support. UCS is on the
latest kernel and they also support containers to some extent.


(André Wismer) #14

@deafsquad

Hi

I’d use Proxmox underneath, that supports both KVM and Containers, both extremly well.
It is also one of the few Linux distris with ZFS out of the box. I don’t use that feature, as most servers don’t have enough RAM.

But Proxmox is specifically built as Host fpr KVM and Containers, unlike other “Genereric” Servers which can do almost everything.

I’m swiss. Take a good swiss army knife (I love 'em). There’s a good knife there, some come with a fork and or screwdriver. But to be honest, I also have a screwdriver set, and there’s a better screwdriver there. In my kitchen I have several, specialized knives, all better than the swiss army knife. A Generic is never as good as a specialist…

On top of ProxMox, I’d use NethServer, which suits me better than UCS…

Your mileage may vary…

My 2 cents
Andy


(Reggie Ho) #15

Sorry for the dropping off this thread for a while… I didn’t get it working completely in Ubuntu LXD either… also I find the performance seems to be poor or lacking compared to running in VMWare ESXi 6.0. After playing with for a while … I gave up … maybe until the new Ubuntu 18.04 version and LXD 3.0 get release, I may give it another go.