Installing Horde Groupware

I got everything up and running now. There is still one problem left: I cannot use the vacation filter in Ingo.
I adjusted the config to use timsieved and to communicate with the local imap server which is dovecot.
The mail server is part of NS. But there I don’t see a possibility in the GUI to use Sieve either.
Does anybody know how to do this?

I’ve read that you have to install


Could you try please.

I had dovecot-pigeonhole installed. But the main point is that you have to create a backends.local.php in ingo which replaces imap with timsieved. The configuration details are shown in backend.php.
After that you have “vacation” in the filter list. It works fine.

1 Like

Thanks Ralph,
if I have some time I would try the configuration of Ingo and add it to my howto.

I resolved this with the following configuration:

Configuration -> Horde -> tab “Authentication”

$conf[auth][driver] = "Let a Horde application handle authentication"
$conf[auth][params][app] = "imp"


2 posts were merged into an existing topic: Password for LDAP bind

I’m running into some trouble on this on my Neth 7.4 machine. The first problem was errors with horde-db-migrate that it couldn’t connect to the mysql server using either localhost or the FQDN as the hostname. I solved that by connecting via unix socket instead, at /var/lib/mysql/mysql.sock.

Then I tried to configure it to bind to Active Directory, and am ending up with this result:

One oddity that might be relevant is that when I run account-provider-test dump, the BindPassword appears to be a 256-character string of non-ASCII characters:
"BindPassword" : "돃㭘斖漿绞粤ꋒ橳㔣砛縞 (cut off, it goes much longer)

When I look at /var/log/horde/horde.log, the only entry close in time to the failure is:
2017-11-17T18:31:14+00:00 EMERG: HORDE [horde] Permission denied. [pid 18146 on line 373 of "/usr/share/pear/Horde/Registry.php"]

Where should I start looking?

Hi @danb35,

you may create an AD User and use that AD user credentials for joining instead of machine and bind password.
Maybe Horde has problems with the binary bind password.

1 Like

I was in the middle of writing a post explaining what further problems I was having when I tried it again. It’s working now. I haven’t changed a thing. :confused: Now I can log in to the horde portal itself as admin or any other user I want, and I can go to admin/config/ and log in as admin.

OK, onward and upward. Going to try installing imp now and see how it goes.

1 Like

I’d been looking at installing this in an AD environment, but it’s looking like I’ll be using local LDAP instead. Any ideas what would need to change? I’m thinking the horde-hook script wouldn’t be needed, possibly replacing samaccountname with accountname? Others?

For LDAP it should be uid instead of samaccountname.

1 Like

Thanks. Would any other changes be called for?

Edit: It’d really be great to see this as a module that could be installed through yum–I’ve been using Horde for the last 15+ years. Other than packaging it myself, which I lack the skill to do, is there any other way I can help make this happen?

1 Like

Hi @danb35 ,
the horde-hook script could be interesting for getting fullname and mail adress from LDAP. Here you can find an example for doing it with LDAP:

I don’t know, I didn’t tried with LDAP, I think some variables like givenname are not the same at LDAP. I’ve found for LDAP it is cn (Common Name).

A beginning could be to create the howto for LDAP-binding and post it.
I think a second big thing could be to create a howto for changing with all data from SOGo to Horde.
Tomorrow is a meeting at FOSDEM. I could ask if there is a chance to replace SOGo witht Horde.

Sounds like some pointers–I’ll see what I can accomplish. Thanks.

1 Like

Thank you too.

I’ve spoken with @giacomo, we should complement the howto with the LDAP part (not a second howto, only implement at the first howto), after that he would look for building a package on nethserver-testing.
There are much more modules which we can install for horde, I think we have to look which ones are important.
Very important too is to activate and test active sync.
At least we should try to export data from SOGo and import to horde.


I can work on the LDAP piece, but I have neither interest in, nor ability to test, active sync. Other than imp and kronolith, already described here, I’d think Turba (contacts) would be pretty important. Following that, notes (Mnemo) and tasks (Nag) should probably be next. I’d kind of like to play with their photo gallery app, and possibly their wiki, but I don’t know that those need to be a high priority for integration in Neth.


I will try and document active sync part, it would be nice if you do so for ldap.

Ok we should try this too.

1 Like

I will try to start working on a basic RPM next week :wink:


I’m trying to adapt the above instructions to use local LDAP rather than the AD authentication, but hitting a problem after I set up the Authentication tab in the horde configuration screens. In short, after I save that configuration, I get a fatal error screen. If I then browse directly to https://fqdn/horde, I’m logged in as Administrator. When I log out, I then am unable to log in as admin. The admin user exists and has a valid password. Here’s what I’ve done to get to that point (apologies for the poor formatting):

Installed per instructions in OP, edited php.ini, created database and user.

Went to /horde/admin/config
Preferences to PHP session – OK
Configured database. Used Unix socket (/var/lib/mysql/mysql.sock) rather than TCP/IP. Clicked Generate Configuration.
/usr/bin/horde-db-migrate – OK
Back to configuration -> preferences -> change to SQL database, Generate Configuration -> OK
horde -> LDAP. Settings at default except as noted below:
useldap -> Yes
hostspec -> localhost
binddn -> cn=ldapservice,dc=directory,dc=nh (from the Domain Accounts page; same is shown by account-provider-test dump)
bindpw -> (password shown there)
basedn -> cn=users,dc=directory,dc=nh
uid -> uid
Generate Configuration – OK

Horde -> Authentication. As above, settings at defaults except as noted below:
admins -> admin
resetpassword -> false
driver -> LDAP authentication
basedn -> cn=users,dc=directory,dc=nh
uid -> uid

Horde -> Groups
driver -> LDAP
basedn -> dc=directory,dc=nh
writedn -> cn=ldapservice,dc=directory,dc=nh
writepw -> (password)
filter_type -> Complete LDAP filter expression
filter -> (objectClass=group)

It’s at this point that I get the Fatal Error screen, but can go to /horde/ to get a login page–but am unable to log in.