Installing from USB

I didn’t test here but on linux when I want to create a bootable usb key, I use the command ‘dd’ or ‘dcfldd’

dcfldd if=path2yourIso of=/dev/sdX

sdX= the name of your key.

But I recall that the creation of the Iso, must use a hybrid setting for this purpose.

Actually I am using a windows PC to create the bootable USB, but I have a laptop with Linux on it I may try that another day

Hi,

Take a look here:

Actually you have two paths:

This has become a trial now and I am at the point of packing in. It maybe the HP micro server hardware but the inability to install easily from a USB iso image is making this more trouble than it’s worth.

Tonight I have started again from scratch, new IS0 on new USB key

Installing nethserver from USB key gets the kickstart error.

Installing CentOS from the options allows you to get to choose a language but then fails because you have to choose a CD/DVD driver but what do you choose when there is no drive, just the USB key.

I have even tried to install just a CentOS ISO with the view to install Nethserver after that but I get the CD/DVD driver error again.

The annoying thing is when this server was installed with Citrix Zenserver I created a nethserver as a VM and it worked like a dream. I wanted to make this hardware a native Nethserver system but am really finding it troublesome and I am thinking, If it is this hard to get the OS on how hard is going to be to get the 4 3TB drives set up and the 3 network ports (one on the motherboard and a dual NIC) working correctly.

I can granted that install from the minimal CentOS is okay.

I do it various time :laughing:

Don’t try to install specific driver, and when the system try to verify the ISO, skip this step :wink:

NethServer is CentOS and the HP MicroServer is supported by CentOS: you may need to contact HP support if you have problems with your hardware.
I have installed NethServer on many HP MicroServer without issues.
When installing from USB you need to select “Install from hard disk” (which is the usb key for linux) and then, probably, sda (look at the volume size, sometimes is sdb).
Again, since NethServer is CentOS, here’re the instructions:
https://wiki.centos.org/HowTos/InstallFromUSBkey
(look at the purple note).

OK People I will persevere and try again this evening…:slight_smile:

Good. :smile:
To be clear, step by step:

  1. install centos from usb
  2. morph centos into nethserver

Step 1 could be achieved following centos docs but also by using the nethserver usb key selecting centos install from the boot menu.
Step 2 is documented here:
http://docs.nethserver.org/en/latest/installation.html#install-on-centos

You mean the USB created with the Nethserver iso, but select the CentOS install ?

Yes, the nethserver usb key is like a centos key with an added directory containing the nethserver packages.

I will try again when I get home tonight… Ii I can get it to work on my N40L I have a nice new shiny Gen 8 microserver to play with too :slight_smile:

NICE toys!.. Got an N40L myself… indeed great for home/soho use.
Low energy use (about 30W on average) and enough space to put in 4 or even 6 disks.
I have 2 2TB in raid1 (mdadm) for /home, 1 250GB for /var and 1 60GB SSD for /

The distro installer it is something that you see normally just one time, but it gives the first feeling of a distro.

From my humble opinion i feel that the installer is a bit tricky…that would mean it can be enhanced…and when you explain …do this…and after do that…for me it is a no way answer.

Now cdrom are tools of the past…nevermind the way…an usb installation must work out of the box

Fortunately for me…i use only virtual environment…even for my real server so i’m not concerned :stuck_out_tongue: … Moving a virtual server is no more than copy and past a file.

1 Like

It’s on the todo list for 7.

4 Likes

great news :slight_smile:

They are nice. I got the N40L from a guy at work when he upgraded. I got the Gen 8 after spotting another money off deal from HP. I had been looking on while on EBAY for a decent second hand one but got new instead.

Well perseverance paid off !
I first unplugged all the connectors and memory fitted in my micro server and reconnected it all just in case I had a bad connection. I formatted the USB and reinstalled the Nethserver iso after downloading it again.

I pulled the 4 drives I had in the front drive bay of the micro server and disconnected and reconnected the 250GB SATA laptop drive I have in the top of the server (where the optical drive would be if I had one) and then put the USB in the USB connector on the motherboard.

Leaving the 4 large drives out, I reconnected the network and powered up.

I chose the CentOS option from the splash screen, chose the hard drive option (sda) and this time it all worked and after about 15 minutes had a base CentOS server

After editing the CentOS config files to get the network connection working the nethserver bit all just worked as described.

Thanks for all your input guys, I have a new native Nethserver running on my HP N40L

:slight_smile:

9 Likes

We have fixed it in NethServer Beta2 @Loboexe @stephdl @jim

2 Likes

Hi,

Great feature the installation from USB.
Installation from CD is something from past.

Only look forma Microserver, or a Netgate 2440… There no Cd or DVD ROM anymore

Jim

4 Likes

If you are using Rufus v3.5 on windows to create the bootable usb disk you must select “dd image mode” (pops up after pressing start).