Installing Avantfax web on NethServer


(Artem Fedai) #1

Hi @giacomo @stephdl ,

I have faced with issue while opening Avantfax web page but it can be consequence of installing httpd update:

Warning: Unknown: open(/tmp/sess_3ec229c4cb7b053749c6f68d047aa95a, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

it works when i add in index php:

ini_set('session.save_path',getcwd(). '/tmp');

Fax Server / FaxWeb 2.0 in English?
(Stéphane de Labrusse) #2

Indeed the 'session.save_path = /tmp ’ is not set in the php.ini, nor in the httpd.conf

Personally I don’t like to share /tmp for all applications, and I use in the virtualhost for example

php_admin_value session.save_path /var/lib/phpMyAdmin/tmp

Of course apache must be the owner of this particular temporary folder.

@davidep @giacomo it is a bug

at least I think that it must be added

session.save_handler                   = files
session.save_path                      = /tmp

@nas you should open a bug


(Davide Principi) #3

what does it actually return that getcwd()?


(Giacomo Sanchietti) #4

I don’t think so, we are (almost) compliant with upstream configuration.

I rather like to add the php option you suggeted for this case inside the httpd conf file, then we can go with the new implementation suggest by @davidep here: Php.ini for NethServer 7