Install on centos 6.5 on ovh vps

# curl -v -L ''
* About to connect() to port 80 (#0)
*   Trying 2a02:2498:1:3d:5054:ff:fed3:e91a... connected
* Connected to (2a02:2498:1:3d:5054:ff:fed3:e91a) port 80 (#0)
> GET /?release=6&arch=x86_64&repo=os HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/ Basic ECC zlib/1.2.3 libidn/1.18 libssh2/1.4.2
> Host:
> Accept: */*
< HTTP/1.1 200 OK
< Server: nginx/1.0.15
< Date: Thu, 26 Mar 2015 15:23:32 GMT
< Content-Type: text/plain
< Connection: keep-alive
< Content-Length: 507
* Connection #0 to host left intact
* Closing connection #0

So, gave up with ovh.

Someone used another vps for testing ?

Just for fun I’ve tried to install NS on Amazon EC2 and I’ve found it pretty easy to do.

I don’t know if it is of your iinterest, but I’ve write a simple How to of the steps here

1 Like

If someone can give me SSH access to a running clean machine, I can give it a try!

I set you a Message with credential. Server has been reseted.

I just successfully installed NethServer on OVH, but there are some problems accessing centos-base and centos-updates from NethServer.repo.

OVH machines resolve host names with IPv6 and CentOS mirror report different answers if queried with IPv4 or IPv6.

To install NethServer on OVH:

yum localinstall -y
rpm --import /etc/pki/rpm-gpg/*
yum --disablerepo=* --enablerepo=nethserver-base,nethserver-updates,base,updates install @nethserver-iso
/sbin/e-smith/signal-event system-init
eorepo nethserver-base nethserver-updates base updates

Also, at the end of the system-init event the machine was stuck and required a reboot.

At the end, I would suggest Digital Ocean over OVS at least for NethServer installations.

Thanks to @enrilor for the collaboration :smile:

P.S. If someone needs more technical details about the problem, please feel free to ask.


I tried few times to install NethServer over CentOS 6.6 x64
with the OVH Kernel, with the distribution Kernel,…
everytime it finishing by an unrebootable server (I think I have a kernel panic)

I also figure this : /sbin/e-smith/signal-event system-init eorepo nethserver-base nethserver-updates base updates
was one line :wink:

And finaly I figured, how to install CentOS from scratch with those instructions
and now NethServer working well on my OVH :smiley_cat:

BTW: In what DigitalOcean is different, I means why It’s easier with them ?

1 Like

These seems small howto for NethServer on ovh, nice!

Never had a single problem installing on DigitalOcean, maybe they use a standard CentOS…

I moved a post to a new topic: Install NetServer on OVH

yes but on digitalocean you have no storage space…ok ssd is cool but if i need a sata/sas disk ? something like >500GB

Just buy a bigger machine! :grin:

1 Like

I moved a post to a new topic: Using NethServer on vCloud of VMWare

A post was split to a new topic: Pb vith NethServer 6,7 and Vserve