Install NethServer on DigitalOcean

For those who want to install NethServer on a DigitalOcean (DO) Droplet’s, this is an HowTo

##Create a droplet

  • I run it under a 512MB droplet’s; but I’ll recommand you a 1GB droplet’s.
  • Select a CentOS 6.5 x64 Image.

##Log over SSH
###Change/give a password to root

  • passwd root
    don’t do any update upgrade

###Run those 4 lines

the last line interacted with the firewall, at one point, your machine will look jam; if you wanna see what happens, use the Console Access (VNC) fonction into the DigitalOcean Panel.

inspired : Install on centos 6.5 on ovh vps

You can simply follow this page:

Tested even yesterday for one of ours projects!

Saddly I’d tried this few times and did’nt work for me

@JOduMonT thanks for your howto, is it really needed? Is there anyone who have already installed NethServer on DigitalOcean? who is right? @giacomo or @JOduMonT ? :smiley:

For sure it’s @giacomo because i’d use is technique :stuck_out_tongue:

I found a mistake and unable to correct it
it nethserver-updates with a hyphen

as we could see here (Install on centos 6.5 on ovh vps)

Hi Giacomo, I tried again this morning
create a new droplet base on Centos 6.7
with the IPv6 option activate

and the only way I could access to %IPserver%:980 it’s with what I posted

when I try the official method : install-on-centos
the installation finish with thoses errors

–> Finished Dependency Resolution
Error: Package: ncurses-libs-5.7-3.20090208.el6.i686 (centos-base)
Requires: ncurses-base = 5.7-3.20090208.el6
Installed: ncurses-base-5.7-4.20090207.el6.x86_64 (@base)
ncurses-base = 5.7-4.20090207.el6
Available: ncurses-base-5.7-3.20090208.el6.x86_64 (centos-base)
ncurses-base = 5.7-3.20090208.el6
Error: Package: glibc-2.12-1.149.el6_6.9.i686 (centos-updates)
Requires: glibc-common = 2.12-1.149.el6_6.9
Installed: glibc-common-2.12-1.166.el6_7.1.x86_64 (@updates)
glibc-common = 2.12-1.166.el6_7.1
Available: glibc-common-2.12-1.149.el6.x86_64 (centos-base)
glibc-common = 2.12-1.149.el6
Available: glibc-common-2.12-1.149.el6_6.4.x86_64 (centos-updates)
glibc-common = 2.12-1.149.el6_6.4
Available: glibc-common-2.12-1.149.el6_6.5.x86_64 (centos-updates)
glibc-common = 2.12-1.149.el6_6.5
Available: glibc-common-2.12-1.149.el6_6.7.x86_64 (centos-updates)
glibc-common = 2.12-1.149.el6_6.7
Available: glibc-common-2.12-1.149.el6_6.9.x86_64 (centos-updates)
glibc-common = 2.12-1.149.el6_6.9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Configuring system, please wait…

/usr/sbin/nethserver-install: line 45: /sbin/e-smith/signal-event: No such file or directory

You can access the Web interface at:
/usr/sbin/nethserver-install: line 51: /sbin/e-smith/db: No such file or directory
/usr/sbin/nethserver-install: line 52: /sbin/e-smith/db: No such file or directory

https://.:980/usr/sbin/nethserver-install: line 48: /sbin/e-smith/db: No such file or directory

I also tried the Install-on-CentOS at exoscale
and I just succeed with my recipe.

BTW exoscale offer the same price of DigitalOcean with more flexibility for the configuration, exemple you could have 8CPU, 1GB of RAM and 200GB of HD.

Here is the problem.
Probably there are some conflicts when installing with the script on a CentOS 6.7 which is not yet supported.

Can you try with 6.6 to reproduce the issue?

DigitalOcean only propose 6.7 now
but i’ll try with a 6.6 next week.

thanks @giacomo giacomo…successfully installed on one of my droplets…:slight_smile:


Thanks for letting us know about it :slight_smile:
Please share here your challenges and achievements