Inotify max_user_watches issue

v7

(James Nesbitt) #1

NethServer Version: 7.4

When I run the command systemctl status minidlna -l I get the following notification:

minidlnad[28169]: inotify.c:199: warn: WARNING: Inotify max_user_watches [8192] is low or close to the number of used watches [100] and I do not have permission to increase this limit. Please do so manually by writing a higher value into /proc/sys/fs/inotify/max_user_watches.

What is the recommended best way to fix this issue?


(Markus Neuberger) #2

Hello @bwdjames,

I found this:
https://ubuntuforums.org/showthread.php?t=2073540&p=12307366#post12307366

I’ll try to reproduce on a testsystem and report…

Uhm, sorry but what did you install to get minidlna?

[root@server ~]# yum list *minidlna*
...
Error: No matching Packages to list

Ah, I found it, did you install rpm or from source?

Tried it with this: https://www.certdepot.net/rhel7-install-minidlna-service/

But I get no error:

[root@testserver ~]# systemctl status minidlnad -l
● minidlnad.service - Minidlna Daemon
   Loaded: loaded (/etc/systemd/system/minidlnad.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2017-10-27 18:15:11 CEST; 47s ago
  Process: 6727 ExecStart=/sbin/minidlnad (code=exited, status=0/SUCCESS)
 Main PID: 6728 (minidlnad)
   CGroup: /system.slice/minidlnad.service
           └─6728 /sbin/minidlnad

Oct 27 18:15:11 testserver.domain.local systemd[1]: Starting Minidlna Daemon...
Oct 27 18:15:11 testserver.domain.local systemd[1]: Started Minidlna Daemon.

(Marc) #3
echo fs.inotify.max_user_watches=65536 > /etc/sysctl.d/10-max-user-watches.conf
sysctl --system

(James Nesbitt) #4

Not sure how I managed to have the max_user_watches to have that value, first time I have seen the warning


(James Nesbitt) #5

Thanks very much, that has fixed the issue