Increased memory usage after switching to FTTH line

is it normal that there is a 95% memory usage? I had already noticed some strange things. for example when I have to assign an ip address: usually I just had to disconnect and reconnect the client and in a couple of seconds it had already acquired the new ip. now, it takes a lot more time. could this be caused by switching from an ADSL line to an FTTH line?


someone had already warned me that a passage to a line with greater bandwidth would have given problems but did not explain why.

It’s normal. You can assign 16GB to Linux and it will use them.
It’s not normal if it starts to use frequently Swap partition because your server performance will be degraded.
You can also read this:

1 Like

however, the problem remains. now, when I change ip address to enable internet browsing, the client does not immediately acquire the new ip.

What IP address are you talking about? The IP on the red interface? Or the server is green-only?



when a new client connects to our network, it receives an initial IP address, with which it is impossible to navigate because the connection is completely blocked. so what I do, is change the IP address or better, reserve an IP address to the client. then disconnect and reconnect the client to acquire the newly associated IP. time: 2-3 seconds. for a week, if I disconnect and reconnect the client, the client does not change its IP, or rather it does so after a few minutes

Does the client workstation get the IP from Nethserver DHCP?
The clients should use Nethserver as DHCP and DNS server and gateway.

Do you use proxy/web content filter?

Yes at all!

You can try disable the proxy temporarily and see if it works.
The first IP it’s a normal IP or an autoassigned?

of course is autoassigned by dhcp

Can you try to disable temporarily the proxy? We can see if it is a proxy problem or other.
Thank you.

I just tried, by turning off the proxy, the internet connection does not work for any of the connected clients. moreover, the problem has not been solved. could it depend on the lease time?

The DHCP on the LAN is totally unrelated to the external WAN connection.

You should check, along with the proxy configuration, also the DNS one.
Connect a Linux machine to your network, check the IP is released correctly (there are no known bug on this on NS), check the machine can access the Internet.

Also make sure to not have another DHCP server running on the same network!

1 Like

Maybe I did not say it clear enough. as soon as the client connects to the network, it receives an initial IP address (temporary, parking). this initial ip is part of an ip range where a filter is set that does not allow you to visit the websites. so every time I have to connect a new client to the network, I have to reserve an ip address (with a filter that allows you to visit the websites).

With your configuration, when the client receive the first address they use them up to the deadline of lease time. It’s normal that they can’t navigate also when you set the address with IP reservation.
After you reserve the IP address correct you should launch these commands on clients:

ipconfig /release
ipconfig /renew

Use ifconfig if you are working on Linux clients.

Let me see if i guess correctly, @nicovon

  • Using a address space
  • is NethServer
  • Nethserver acts also as WINS server

(post screenshot in english helps comprehension for other language people. I’m Italian, i can understand perfectly but sometimes for other guy could not be the same)
Next steps:

  • which was your RED IP setup?
  • which one is now?
  • did you change network properties on red connection? (bandwidth)
  • do Nethserver now use swap? If yes, how many?

Yes, right, but I’ve never done it before. there was never a need to execute these commands

It’s strange. Lease time is default for 24 hrs. IP doesn’t change before this value.
You can reduce lease time, it depends on your needs.