Import from Outlook, folder structure, how too move any delete folder?

I imported an Outlook PST into Nethserver 7.8.2003.
However, instead of the INBOX (“Posteingang” in German) all Mails from Outlook are in a separate folder “Outlook-Datendatei” with a separate “Posteingang” und “Gesendet” folder.

I cannot move or delete any of the folders under “Outlook-Datendatei”.

How to move all the structure into the current folders and delete unneccessary folders?

What client do you use on NethServer? SOGo, Webtop or roundcube?
What happens with the folders if you connect with a mailclient like Thunbderbird? Can you delete the folders then?

I use Webtop5. With Thunderbird I get an error message.

I can even create new subfolders under the imported Outlook folder, but I cannot delete then afterwards.


Hallo Carsten

What did you use to import the PST file?

It seems that the permissions aren’t set correctly.
Check the permissions here:

ls -l /var/lib/nethserver/vmail 

Your permissions should look something like this:

The user/group is the same for all subfolders in that directory.

Specifically check the imported structure (= Outlook-Datendatei ).

You may need to use a chown/chmod…
But check first from which level your permissions aren’t correct and do a chown/chmod from there first.


The vmail directory is where Dovecots (The IMAP Mail programm) has it’s user-mailboxes.
This is not Webtop specific, this serves all mail programs / clients…

chown -R vmail.vmail /var/lib/nethserver/vmail/
chmod -R 700 /var/lib/nethserver/vmail/

should do the trick.

Maybe that helps

My 2 cents

Hi @Andy_Wismer,

thanks for you answer.

I deleted and recreated the user and the permissions were correct than (but before they were not, but I have no idea why).

Now I am able to move SOME of the folders still not all. I see that some folders are displayed with black type, and these can be moved and deleted (like “Einladungen”), and others in grey type, which cannot ibe moved or deleted (like “Büroleitung”).

What is the reason for this and how to change it?

Can I just move everything on the file level, or does anything speaks against this?

It would be nice, if the import script had a folder mapping. I don’t know how people migrate many users when there is plenty of manuel work to do to move the folders and contents.


Hi Carsten

AFAIK, as long as the permissions are right, you can move the folders manually - they are, after all, folders…
Just make sure you have the permissions intact AFTER moving…

What mail client are you using besides Webtop, Thunderbird?
Check with a mail client too.

Both may need a reindexing of the folders, on Thunderbird you can init that by changing something in the “Abonieren” and changing it back to include all folders. That will triger a reindex in Thunderbird.

My 2 cents

I use Webtop5. Is there also a reindexing necessary and how to do it?
There seems to be some special attribute, which makes folders undeletable and unmovable und grey in the Webtop5 display. I would really like to know, which settings this is.


Do mails appear correct in Thunderbird (or any other mail client)?

I’m sure there’s some special command like update-webtop which reindexes the mailfolder.
But as I don’t use Webtop, maybe someone of the @webtop_team can help here… :slight_smile:

My 2 cents

I found out what makes the folders grey: It the Umlauts in the folder name like “Müller” and the mUTF7 default for folder names in dovecot. The nethserver import script however imported folder names in UTF8.

The UTF-8 folder name are displayed in Webtop but in grey and cannot be accessed. Thunderbird cannot access them either.

Here the difference in the filesystem (the latter “Müller” folder was created in Webtop)
UTF-8: drwx------ 5 vmail vmail 60 Jul 3 23:37 .Outlook-Datendatei.Posteingang.Müller
mUTF7: drwx------ 5 vmail vmail 154 Jul 4 06:28 .INBOX.M&APw-ller

After setting Maildir format to UTF-8 in dovecot.conf everything work. There are three lines to change.

mail_location = maildir:~/Maildir:UTF-8
location = maildir:/var/lib/nethserver/vmail/%%u/Maildir:UTF-8
location = maildir:/var/lib/nethserver/vmail/vmail/Maildir:INDEXPVT=~/Maildir/public:UTF-8

The other possibility would be to rename the files from UTF-8 to mUTF-7 which should be done by the nethserver outlook import script.

I think the preferred way should be to go into the direction UTF-8 for all character encodings, so the Nethserver should support UTF-8 Maildirs (maybe as an option).


Good to see you could solve the problem. @dev_team @webtop_team can there be a more permanent solution for this? I can imagine more (especially in the German speaking regions) members can run into this problem.