Imapsync not delete profile

Hello everyone, I can’t delete an imapsync profile.

{"context":{"action":"delete-task","data":{"localuser":"francesco","task_id":"b9yq7f"},"extra":{"eventId":"768a6bec-1785-4be3-95b3-1095c7adb230","isNotificationHidden":true,"title":"action.delete-task"},"id":"3c19d513-8ff4-4191-970f-f32d47b81f66","parent":"","queue":"module/imapsync1/tasks","timestamp":"2024-06-13T19:33:40.236305506Z","user":"admin"},"status":"aborted","progress":0,"subTasks":[],"validated":false,"result":{"error":"<7>run-imapsync stop francesco_b9yq7f\n/usr/local/bin/syncctl: /etc/imapsync/francesco_b9yq7f.env: line 10: inviata$: not found\nTraceback (most recent call last):\n  File \"/home/imapsync1/.config/actions/delete-task/10stop-service\", line 16, in <module>\n    agent.run_helper(\"run-imapsync\", \"stop\", localuser+'_'+task_id).check_returncode()\n  File \"/usr/lib64/python3.11/\", line 502, in check_returncode\n    raise CalledProcessError(self.returncode, self.args, self.stdout,\nsubprocess.CalledProcessError: Command '('run-imapsync', 'stop', 'francesco_b9yq7f')' returned non-zero exit status 127.\n","exit_code":1,"file":"task/module/imapsync1/3c19d513-8ff4-4191-970f-f32d47b81f66","output":""}}

Also, even if it is scheduled, is it normal for it to be stopped?

I can’t reproduce.
Are there special characters in the used password?
Can you create another task (using another mailbox) and delete it?
Please share logs to hopefully get a direction to the error there…

Yes, not running scheduled jobs are shown as stopped.

Hi Mark, no, the characters of the password are the ones I used it for 2 months. I tried to create another same accou nt, but it doesn’t make me cancel the first one.
I don’t understand … it’s always worked .

Can you show me in private the name of your account and the content of the command tree

You can sort with tree the content of the state and find the account credentials it start with the name of user and end with a random string : user_1fe45dj

I recall at least three files to remove, settings, password, cron, simply remove all the files

tree /home/imapsync1/.config/state

It is the second time it happens :-?

Thanks @stephdl , as soon as possible I will do these tests . At the moment I can only answer you that the second account equal to the first seems to work .

1 Like

new bug for @france


Jun 14 16:40:42 ns8 agent@imapsync1[192613]: /usr/local/bin/syncctl: /etc/imapsync/francesco_b9yq7f.env: line 10: inviata$: not found

the content of the file francesco_b9yq7f.env gets this

EXCLUDE=,^.*Posta inviata$

Thanks sthepane I won another bug award !! :rofl: :rofl: :rofl: