Imapsync - mapping folders manually

Hi there, hi @mrmarkuz,

I just used the imapsync module for the first time today and I’ve a few remarks / requests :

  • I had some difficulties to connect to OVH’s mail server, they’re really selective as of how one can log in (SSL + port 993 mandatory) and the FQDN one has to use is not clear. I had to look to the logs to understand what was going on. Maybe reporting that error message in the GUI would help users.

  • Because OVH is French, the IMAP folders are in French too :roll_eyes:. imapsync struggles to figure out how to map the remote / local folders when names differs. I wish there was a way to manually map i.e Sent Items and Eléments Envoyés from the GUI. That might be a nice improvement since imapsync supports that.

Thanks :slight_smile:


1 Like

Just pinging @stephdl
Of course, not for today’s La Toussaint. Take care.


I don’t think you can do folder matching in the GUI version.
You would have to work at the scripting level.

1 Like

I am not sure it is a good reason, so let push the joke, tomorrow the provider is japanese and I will need to adapt it.

Change your provider :smiley: or do it a the script level, when you save the form we create a systemd service to sync the imap folder, you can modify it

the imapsync systemd name :

the ENV file you can modify :

the systemd template of the service :


That’s why I used imapsync :blush: OVH is not reliable anymore and their administrative mess is unbearable nowadays.

I agree that my user case is probably not so usual. Thanks for pointing me the files that might help me customize the thing. I still have to figure out how to handle the UTF8 encoding for “Éléments envoyés” :slight_smile:

My idea at first was presenting a treeview of remote and local inbox to help the user map the folders but I understand that a bit too much asking :blush:

Bye Steph,


1 Like

@stephdl sorry, it’s been a long time since I fiddled with nethserver’s templating mess :joy:

I tried to edit /usr/lib/systemd/system/imapsync@.service and added --f1f2 "&AMk-l&AOk-ments envoy&AOk-s" = "Sent".

The setting doesn’t look to be taken into account looking at the log file. What should I do ?

Maybe you could add that setting into the GUI ?


1 Like

Systemctl deamon-reload

I bet

you have modified the systemd template that will write the systemd service for your user.
but not exactly the systemd user

Damn you’re right of course :blush: