I fell at the first hurdle

domain

(Peter Humphrey) #1

At about the fourth attempt at installation I finally got a root login. Almost the first thing the configurer wanted was an FQDN - which absolutely had to have two dots in it. Mine doesn’t. It’s an intranet, with no accessibility from outside, so the name is neth.mynet. Why can’t I use that? I’ve been running Gentoo with that network name for many years with no problem. What do I have to do now?


Restore Data Backup from 6.9F to 7F
(Jeroen Visser) #2

Make it neth.mynet.local is all you can do. A FQDN requires 2 dots. Hostname.domainname.tld

Since nethserver can be used as openldap and ad server, the hostname should be forced to a FQDN, to avoid other issues.


(Peter Humphrey) #3

Make it neth.mynet.local is all you can do. A FQDN requires 2 dots.
Hostname.domainname.tld

Doing that would throw the rest of mynet into chaos and I’d have to rejig
the whole LAN. I’d prefer to call this box neth.host.mynet - or does Neth
check for my TLD being in its list? Also, I found a lot of argy-bargy on the
web about the advisability of .local.

Since nethserver can be used as openldap and ad server, the hostname
should be forced to a FQDN, to avoid other issues.

I see your point, but I have no need of either of those so I prefer to evade
the issue. That is, if I decide to give Neth another go.

Thanks for the advice.


(Jeroen Visser) #4

You could use neth.host.mynet I’d think. Not sure if there averse effects to such a hostname. It wont work properly if you want to enable the mailserver on internet for instance.

I am not sure how strict the two dots are enforced. Chances are only the gui will check that. Maybe setting your hostname directly in /etc/hostname would work. Worth a try I’d say.

Edit: This would need to be a custom template tho, as I just confirmed the hostname is set through the e-smith system. Not sure which template to edit how. Maybe the more knowledgeable Nethserver people can chime in here.


(Dan) #5

You do if you’re planning on authenticating users to your Neth box–unless you’re tying it to a remote LDAP or AD server.


(Peter Humphrey) #6

No, this is a tiny, personal LAN, not a corporate intranet. I am the only physical user at the moment.

Actually, it turned out to be easy to switch my domain from mynet to mynet.local. I just needed one command on each box:

grep -lr mynet /etc | xargs sed -i ‘s/mynet/mynet.local/g’

Then just restart the network.

I’ll try again with this setup until I can come up with a safer solution. Thanks for all the help.


(Stefano Zamboni) #7

sorry, but you’re doing it in the wrong way
Nethserver is not a plain centos, it’s an highly customized centos… you can’t simply edit configuration files.
Believe me, you’d better start from scratch with a new install and do the things in the NS’ way


(Markus Neuberger) #8

I hope you wrote about the client boxes. If not, please do like @Stefano_Zamboni recommended.

You may use the DHCP server of NethServer to configure your clients from a central point. You are also able to set a domain for the clients:

http://docs.nethserver.org/en/v7/dhcp.html