I added a new network interface and now I cant access the server

can anyone assist via command line on how to make it so I can get back in…sorry…newbie.
I added a network and then deleted it( I think) and now I cant access via web browser
was eth0 green
static ip was
network was

it appears I changed my interface from eth0 to bond0

I’m guessing your NS is installed on physical hardware and you swapped network adapters?
So if you’re sitting in front of it, you could use ifconfig to see the current adapter settings and the commands to set an ip if need be are easily available by google.

If you’re locked out by firewall settings, you didn’t say, then you might be able to use shorewall commands to change them.

it is on physical hardware.
I did that and got what looks correct except that what should say eth0 says bond0

the role property for eth0= should be green and instead there is nothing there

Hi friend @marklab

Vi /etc/network/interfaces

auto eth0
iface eth0 inet static
gateway xxx.xxx.xxx.xxx

Actually, thanks for the input…I followed instructions here:
and got everything back.
Thanks very much again.


Ok…so I got access to the server back but I cannot access via samba anymore after following this: http://docs.nethserver.org/projects/nethserver-devel/en/latest/network.html
any ideas please?


signal-event nethserver-samba-update

If it doesn’t work, check all networks listed inside the smb.conf.

1 Like

yeah…only thing listed in interfaces and hosts allow is the localhost
can I add via command line.
the network shows up in the web interface but not in the smb.conf

when deleting the trusted network and reentering I get this:
Task completed with errors

Template /etc/httpd/conf/httpd.conf #5 (exit status 1)
expansion of /etc/httpd/conf/httpd.conf failed
Template /etc/samba/smb.conf #6 (exit status 1)
expansion of /etc/samba/smb.conf failed
Template /etc/shorewall/hosts #33 (exit status 1)
expansion of /etc/shorewall/hosts failed

Dashboard indicates
lsm (Link Status Monitor) enabled Stopped

So…it looks like I did not delete the file /etc/sysconfig/network-scripts/ifcfg-bond0
when resetting the network configuration using:


All appears good now…“not bad for a newbie”? Hope I didn’t waste anyones time.
Thanks all!


Really not bad! Can you mark the topic as resolved?
Please, say thanks to these guys introducing yourself here!