HTTP Status 404 - /guacamole/

NethServer Version: latest
Module: nethserver-guacamole from mrmarkuz repo

Tried to install guacamole on a fresh installed ns and got this:

Are there any prerequisites?

No prerequisites. Make sure tomcat has finished starting or restart tomcat service.
@mrmarkuz, there are some references to mattermost on the spec file that might need to be fixed.

1 Like

I think I solved it, I did a recovery of the vm and tried it again.

Now I used:

yum install -y nethserver-guacamole

instead of

yum --enablerepo=mrmarkuz install nethserver-guacamole

Next problem:

After I tried to remote control a client I get this in a loop:

grafik

A reboot doesnt help either…

Maybe you can get out of the loop by using the guacamole menu (CTRL-ALT-SHIFT):

https://guacamole.apache.org/doc/gug/using-guacamole.html#guacamole-menu

Could you post the connection settings you used to check if they are correct?

Thanks, I am going to check.

EDIT: A copy/paste error. I tried to upgrade to guacamole 1.1.0 to make Swiss German work and took some code from mattermost but no success so far, see Howto install guacamole
The package in the repo is not affected.

Thank you folks, finally I got it working. I installed it a 3rd time (recovery) and with the right client configuration I can work with it now.

Do we have examples for the client-config under guacamole?

I did not find an overview of config examples but there should be a lot of guacamole tutorials describing the configuration.

Usually only hostname and port have to be configured.

1 Like