HowTo install Wordpress on NethServer

intermediate
application

(Vasco) #21

Installed

The file has the option allow from all

Already in the file

I have the an error and don’t work
The error in the log is: [Tue May 19 11:56:07 2015] [alert] [client 192.168.175.13] /usr/share/wordpress/.htaccess: RewriteEngine not allowed here


(Stéphane de Labrusse) #22

try to change to
$OUT .= " AllowOverride All \n";
then
signal-event nethserver-wordpress-update


(Vasco) #23

Now it works

Many thanks


(Stéphane de Labrusse) #24

Merci vcc…a new rpm will come tonight please stay stuned to verify it


(Jonathan Dumont) #25

I just install with success WordPress via

  • yum install nethserver-nethforge-release
  • yum install --enablerepo=nethforge nethserver-wordpress

but I want wordpress respond into my http://domain.tld/

so I just need to change the config into httpd and wp-config and run

  • config setprop wordpress /
  • signal-event nethserver-wordpress-update
    ??

And did’nt trully understand the part about the .htacess because, I tried to rename my permanent link and that blow up my website.


(Roy Esterhuizen) #26

How do I make wordpress run in mydomain.com instead of mydomain.com/wordpress/


(Jonathan Dumont) #27

Hi Everyone;

Now we are 2persons asking the same thing :wink:

I tried to redirect with this command

like
config setprop wordpress URL /
signal-event nethserver-wordpress-update
OR
config setprop wordpress URL .
signal-event nethserver-wordpress-update

but I just receive an error after.


(Alessio Fattorini) #28

Hope @stephdl can we help us :cry:


(Jonathan Dumont) #29

The only way i’d succeed it’s to use the web access
http://docs.nethserver.org/en/stable/shared_folder.html#web-access and install wordpress as a web site root


(Stéphane de Labrusse) #30

the URL is just here to change the name of the folder eg ‘wordpress’

if you want to change the url to a root domain name you can try the following command, you need to declare this domain in the server-manager.

# vim  /etc/httpd/conf.d/roundcubemail_domain.conf
<VirtualHost *:80>
ServerName roundcubemail.example.org
Redirect permanent / http://roundcubemail.example.org/roundcube
</VirtualHost>

and

 signal-event nethserver-wordpress-update

This should be added as a nfr.


(Luciano Vicentini) #31

Hello someone already installed Wordpress on NS 7.2?


(Alessio Fattorini) #32

Not tested yet, do you wanna give it a try? You’re welcome! :grinning:


(Luciano Vicentini) #33

Hello all,

Anyone know how to change the root directory of wordpress, example:
http://mydomain.com/wordpress to http://mydomain.com

Thanks a lot.


(Alessio Fattorini) #34

Check the post above
HowTo install Wordpress on NethServer


(Luciano Vicentini) #35

Not work, I changed the configurations files to wordpress, but not work.

/etc/httpd/conf.d/wordpress.conf

After running the command (signal-event nethserver-wordpress-update) the contents of the file “/etc/httpd/conf.d/wordpress.conf” back to its original state.

I tried replacing the directory / wordpress by “/” and “.” the settings (config SetProp wordpress URL.), but also did not work, Apache continues to show the default page, both http and https.

In /etc/e-smith/templates/etc/httpd/conf.d/wordpress.conf/10Conf the option AllowOverride this $ OUT = “AllowOverride All\n”;

Does anyone have any idea how to make wordpress works at http://domain and not the http://domain/wordpress?


(Stéphane de Labrusse) #36

This cannot be done easily, it must be implemented by a new feature


(Giacomo Sanchietti) #37

You need to hack httpd configuration.
Otherwise you should do like this:

  • create an alias for the server
  • create an ibay with web access
  • set the ibay as document root for the created alias
  • tweak all permissions with .htwrite file

(Stéphane de Labrusse) #38

a quick fix, but It needs some works

vim /etc/httpd/conf.d/wordpressredirection.conf

<VirtualHost 0.0.0.0:80>
ServerName toto.com
ServerAlias www.toto.com
DocumentRoot  /usr/share/wordpress 
</VirtualHost>

and

service httpd restart

then go to the panel dns/server_alias of the server manager and declare the domain toto.com

the problem to solve now comes the way where and how wordpress saves the url in its database, please read this https://codex.wordpress.org/Changing_The_Site_URL

In fact my method is good if you install it from scratch, but if you do it on an already installed wordpress, you will find a lot of broken url.


#39

I’m so confused.

Is it;

service httpd restart

or this;

signal-event nethserver-httpd-update

?

is simply restarting apache enough?


(Stéphane de Labrusse) #40

since you don’t add a new template ‘service httpd restart’ is enough but you can also use ‘signal-event nethserver-httpd-update’ because it restarts also httpd