Howto install Onlyoffice document server as Nextcloud app

thank you

1 Like

Hi everyone,

Yesterday i made a clean install Nethserver + Nextcloud (from Software center) + OnlyOffice + DocumentServer 5.1.4 as per instructions (onlyoffice Wiki).

Despite this, I have always received an error (when I press the Save button in Nextcloud - ONLYOFFICE):
“Command Request on check error: Error while downloading the document file to be converted.”

I spent the whole day trying to solve the problem.

I found a solution this morning. In file default.json (/etc/onlyoffice/documentserver/) I made a simple change (true to false):

“requestDefaults”: {
“headers”: {
“userAgent”: “Node.js/6.13”
“rejectUnauthorized”: false

I know the problem is in the certificates, but only in this way have I managed to make Onlyoffice to work.

I am a little confused :roll_eyes:

1 Like

Hi Zoran,

Yes, you need a valid trusted cert like letsencrypt and you probably need to port forward 8082 from your router to your Nethserver. You have to set your domain too.

Thanks for sharing, this is great for using onlyoffice without valid cert but I am afraid it’s not the best for security.

1 Like

Thanks Markus,

now I will try to implement the certificates.

Hi Markus @mrmarkuz ,

I installed a new NS instance with NC-13.0.6 and only-office 5.0.7 (selfsigned certs).
I had to install librabbitmq and librabbitmq-tools from puias-unsupported.

I did:

and then

yum localinstall -y librabbitmq-0.5.2-1.sdl7.x86_64.rpm
yum localinstall -y librabbitmq-tools-0.5.2-1.sdl7.x86_64.rpm

Now onlyoffice in NC 13 on NS 7.5 is running fine:

Maybe you want to update your Howto.


IIRC it’s only a problem with old documentserver needed for self-signed certs, newer documentserver version should just work. It’s because epel changed rabbitmq packages.
Thanx, I’ll update the wiki entry asap.

EDIT: updated.


4 posts were split to a new topic: Content server runs, but no onlyapp options

I found a workaround to install onlyoffice 5.1.x with selfsigned certs.
It’s only a workaround, because it breaks SSL security due to allow connections to unauthorized ssl servers, but it works.

Set services.CoAuthoring.requestDefaults.rejectUnauthorized=false in /etc/onlyoffice/documentserver/defaults.json file and restart documentserver serviceis with supervisorctl restart all .

Got it from:


I updated the module. Please test it so I can put it to the repo!

To update an existing installation (for a full install follow the wiki except of these two lines):

yum -y install
yum -y install

It seems the formats were extended too:



Just saw, that I posted the same solution as you did before. Sorry :blush:
I didn’t read this topic exactly enough.
I could have saved half a day of searching if I had done… :wink:


Worked here like a charme! Thanks Markus! You are great !:+1:
PS: selfsigned certs still work with changing “true” to “false”.


Thanks for testing! For the self-signed certs there’s a db prop now too:

I am afraid of future documentserver updates may change the default.json so I decided to add it.


Late to the party. Thanks @mrmarkuz and @flatspin good job! This project is growing day-by-day

I tried to get started with Onlyoffice following wiki documentation but using DocumentServer 5.2.3.

The server didn’t start. Quick and ugly fix:

chown onlyoffice:onlyoffice /etc/onlyoffice/documentserver/default.json
supervisorctl restart all
1 Like

Thanks, I can confirm this, it seems they changed something in 5.2 but I can’t find documentation about it.

I am going to investigate, only found this for the moment, default.json is read-only now and config should be saved in another file:


Here is the changelog, but I can’t find something about it too.

1 Like

hello, help me.
Some time ago I made my first installation of ONLYOFFICE and everything went wonderfully.
A few days ago I’m trying to do some installations but I can not start the APP.
I have created more virtual machines with Neth 7.5 or 7.6, update, but the result is always the same.
I do as follows:
I install Nethserver 7.5 or 7.6
I install LDAP
I do everything that the WIKI says

This is the result:
test the document server.


Then try to open file .docx

Did you allow self-signed certs? It’s necessary with newer documentserver versions:[]=onlyoffice#self-signed_certificate


Hi, Markus
Tomorrow i’ll try and then… I hope

1 Like

When I click on a document in nextcloud im getting the error “ONLYOFFICE cannot be reached. Please contact admin” i can access via i get the screen says document server running below is my onlyoffice setting in nextcloud