Howto install Odoo 11

These LDAP settings work for me:

Server Information
LDAP Server address:
LDAP Server port: 389
Use TLS: no

Login Information
LDAP binddn: cn=ldapservice,dc=directory,dc=nh
LDAP password: password of ldapservice user

Process Parameter
LDAP base: dc=directory,dc=nh
LDAP filter: (&(objectClass=person)(uid=%s))
Sequence: 10

User Information
Create User: yes
Template User: [Demo User] (just for testing, create a template user for production)

For AD settings see Howto install Odoo 10

Hi @mrmarkuz ,
Thanks for reply.

i did same settings but users are not replicated. My odoo11 is with NS reverse proxy and hosted on same server, as followed your post. please see below settings. Please help me to resolve this.

There’s no replication of all users.
When you login to Odoo with an LDAP user the first time, the user is created from the template user in the odoo database.

Hi @mrmarkuz,
I couldn’t understand this point of integration. NS has Ldap and Odoo is connected with NS Ldap, Conceptually NS users should login in odoo and odoo users should login in NS.
why if you create a user with Odoo not be able to use the same login credential for Mattermost or nextcloud or email or other services in NS7 vice-versa.
Please clear my doubts. Great thanks to you.


I’m sorry, this is how the Odoo module works.
On Odoo login, the user login is checked against the odoo database. If there’s no user entry then LDAP is searched. If the user is in LDAP database it is created in the odoo database.

Why do you need replication of all users?

If you create a user on Nethserver, you can login to Odoo with this user like you can login to Nextcloud.
Management of LDAP users should be done with Nethserver and not in the served applications.

Mattermost doesn’t use LDAP:

I want only integrate NS with LDAP and these users should authenticate with odoo. If NS users, they should be able to login.

Hi @mrmarkuz
i have added all setting of NS LDAP and both (NS+odoo) are on the same server. As followed ldap creds.
[root@cloud odoo]# account-provider-test dump
“BindDN” : “cn=ldapservice,dc=directory,dc=nh”,
“LdapURI” : “ldap://”,
“DiscoverDcType” : “dns”,
“StartTls” : “”,
“port” : 389,
“host” : “”,
“isAD” : “”,
“isLdap” : “1”,
“UserDN” : “ou=People,dc=directory,dc=nh”,
“GroupDN” : “ou=Groups,dc=directory,dc=nh”,
“BindPassword” : “_8CNwb_SkSf9cHkZ”,
“BaseDN” : “dc=directory,dc=nh”,
“LdapUriDn” : “ldap:///dc%3Dzenlab%2Cdc%3Dit”

But when i am integrating with odoo Ldap module and written all settings into required fields. But i am not getting any successfull logs, pls go through my logs.

pls help me to troubleshoot this.

Please check if you use a correct LDAP filter.
In your screenshot you use an LDAP filter for Active Directory. In LDAP uid is used instead of samaccountname.


i have tried this LDAP filter: (&(objectClass=person)(uid=%s)) But still not solved.

What exactly is not working now?

From the logs it looks like the odoo user is created when logging in as ldap user so you should be able to login with LDAP users.

LDAP users means (Nethserver Users) are not able to login in odoo. This the issue.

Did you try to use only the username without domain like “test34” instead of "" at login?

i tried both with domain and without doamin. But not able to login from NSUsers in odoo portal.

I tested on a fresh Nethserver VM with LDAP (not AD) and Odoo 11 and still can’t reproduce.

The “Login failed” error is normal at first login but the next log line should be about creating a new Odoo user:

INFO odoo odoo.addons.base.res.res_users: Login failed for db:odoo login:odoouser2 from
DEBUG odoo odoo.addons.auth_ldap.models.res_company_ldap: Creating new Odoo user "odoouser2" from LDAP

The LDAP user now should be logged in. At next login you should see following line:

INFO odoo odoo.addons.base.res.res_users: Login successful for db:odoo login:odoouser2 from

It seems your LDAP module is not working because the Odoo user is not created.

Just a blind shot, do you use special characters in the user passwords?

Please share your odoo log in text format with a tool like pastebin (don’t forget to hide passwords)

Hi @hector

AFAIK, you need to get a valid SSL for your AD (Easy enough if running on NethServer).
A lot of Apps, especially Java and PHP programmed stuff, which can use AD require a valid SSL.

Here’s the link about AD n NethServer:

Search for the sub-title " The next step will make sure that java and other more strict apps can connect to the AD and use it :"…

You will still need to change the LDAP into LDAPs in the query, and also change the LDAP Port to 636.

Dirección del servidor LDAP ldaps://
Puerto de servidor LDAP 636

As to TLS: you may need to try both options, I think TLS should work.

Good Luck!

I have this working at home, not for Odoo, but a similiar “strict” App…

My 2 cents


It doesn’t work in odoo

In Zabbix and GLPI LDAP is working pretty well, but unable to do it in Odoo14 don’t know the reasons.

¿Any ideas how to debug LDAP querys? I have samba AD configured in the server.

With a valid AD ssl cert?

Odoo is not asking for valid cert, it does have an option for do not verificate the certificate.

Nothing to do with odoo, maybe the filter settngs help…

Hi @hector,

Is LDAP port 636 opened?

# cat /etc/shorewall/rules | grep 636

Try to search a user (notice the ldaps://):

# ldapsearch -x -H ldaps://Ldap-Server-Dns-Name -D cn=ldapservice,dc=directory,dc=nh -w "BindPassword" -b dc=directory,dc=nh  |  grep "User-Name"

Obvious but sometime… - Is Odoo-14 running correctly?

# systemctl status odoo14 | grep -i Active

Maybe you can try to enable debug in Odoo by changing WARNING to DEBUG:

# cat /etc/odoo-server.conf | grep log_handler
log_handler = werkzeug:WARNING
;log_handler = :DEBUG