How to use Upstream Proxy

proxy

(ch312131) #1

Hi,

Somebody pls explain me how to use upstream proxy for Nethserver, my network setup as follows

Proxy server IP 192.168.54.40:3128(Support transparent mode too) and i have another Nethserver in Subnet 192.168.60.0/24
for Subnet 192.168.60.0/24 Nethserver ,i want to assign 192.168.54.40 proxy for internet access.

Thanks,


(Markus Neuberger) #2

You may set it in Configuration / Network / Proxy Settings:

grafik


(ch312131) #3

I was tired to use as same but users how are on 60 subnet can’t browse internet.

and their gateway is 192.168.60.2(nethserverIP)


(Markus Neuberger) #4

I am afraid transparent mode won’t work that way, did you try manual mode?
What about setting up a transparent proxy on 192.168.60.2?


(ch312131) #5

i have assigned 192.168.54.40 and port 3128 in 192.168.60.2 nethserver.

(subnet 60 clinet can access internet if i assign 192.168.54.40:3128 on their internet explorer) but my requirement is using same 54.40 nethserver as primary internet firewall,

is it required to configure transparent proxy setup in 192.169.60.2 nethserver??

can i use port forwarding for this requirement, as example, all subnet 60 http/https traffic forward to 192.168.54.40 port 3128.??


(Markus Neuberger) #6

And the gateway of the 192.168.60.2 nethserver is 192.168.54.40? Then it should work even without setting proxy for the clients.

In this case the 54.40 nethserver is firewall and proxy.

No, not necessarily, it was just an idea.


(ch312131) #7

No, 192.168.60.2(nethserver) gateway is 192.168.60.1 as its behind a router.

this requirement behind the scenario is,

01.subnet 54.0 is only having internet connection and users who are in the 54 subnet their http and https traffic route to 192.168.54.40(let’s say gateway is 192.168.54.40)

02.subnet 60.0 doesnn’t have internet connection in physically place in there and subnet 60.0 getway is 192.168.60.1

now the requirement is place nethserver in subnet 60.0 and configure installed nethserver to communicate upstream connection with192.168.54.40 proxy for internet access of subnet 60.0 clients


(Markus Neuberger) #8

I think I misunderstood you. To have the 60.0 clients using transparent proxy so you don’t need to configure your clients, you may configure a transparent proxy on the Nethserver.

As your outer proxy is transparent too you shouldn’t need the parent proxy setting. To ensure proxy is used you may block HTTP/HTTPS ports.


(Alessio Fattorini) #9

@Chathura_Priyasad did you resolve thanks to Markuz’s suggestion?


(ch312131) #10

this work.thank you.