How to turn on ejabber Chat Server?


#1

My nethserver is accessible to the open internet by the fully qualified domain name. To get the chat server working I changed the host name to my fqdn

nano /etc/ejabberd/ejabberd.cfg

and then I edited this section

% Host name: 

{hosts, [“server1.example.com”]}.

I was able to login using Pidgin on my desktop and Xabber and Chat Secure on my android device.

I tried to access the ejabber server admin panel however I was unable to. The dev docs said that by default the admin panel is disabled. I am unsure of how to turn it on.


(Giacomo Sanchietti) #2

You don’t have to modify configuration files by hand, just change the server name to the public one.

To enable web admin panel:

config setprop ejabberd WebAdmin enabled
signal-event nethserver-ejabberd-save

See: http://docs.nethserver.org/projects/nethserver-devel/en/latest/chat.html


Chat server host name problem