How to send mail with link

nextcloud
v7
mail

(Christian Plaza) #1

Hello how I can send mail with the link of the document in nexcloud I put a mail but doesn´t send.


(Markus Neuberger) #2

I tried it now and it works from Nextcloud but it requires working mail. Are your users able to send mail?

Maybe Nextcloud@YOURMAILDOMAIN.TLD is not allowed to send mails via your smarthost?

You may look in /var/log/maillog if a mail was sent and if there was an error.


(Christian Plaza) #3

If I can send the link to a gmail, yahoo or hotmail… can I…?


(Christian Plaza) #4

I have this errors…

Dec 29 15:50:19 sdhg postfix/smtp[40549]: connect to gmail-smtp-in.l.google.com[74.125.141.26]:25: Connection timed out
Dec 29 15:50:19 sdhg postfix/smtp[40549]: connect to gmail-smtp-in.l.google.com[2607:f8b0:400c:c06::1b]:25: Network is unreachable
Dec 29 15:50:22 sdhg postfix/smtp[40549]: connect to alt1.gmail-smtp-in.l.google.com[209.85.202.26]:25: No route to host
Dec 29 15:50:22 sdhg postfix/smtp[40549]: connect to alt1.gmail-smtp-in.l.google.com[2a00:1450:400b:c00::1b]:25: Network is unreachable
Dec 29 15:50:37 sdhg postfix/smtp[40549]: connect to alt2.gmail-smtp-in.l.google.com[173.194.76.26]:25: No route to host
Dec 29 15:50:37 sdhg postfix/smtp[40549]: DA8E1C00A7AB3: to=christian.plaza@gmail.com, relay=none, delay=82657, delays=82584/0.01/73/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[173.194.76.26]:25: No route to host)


(Markus Neuberger) #5

It seems you cannot reach the server gmail-smtp-in.l.google.com on port 25. You may change the port to 465 (SSL) or 587 (TLS), see https://www.lifewire.com/what-are-the-gmail-smtp-settings-1170854
Did you block gmail/webmail in some way?
Can you ping gmail-smtp-in.l.google.com? Does it work if you deactivate content filter/proxy?


(Christian Plaza) #6

I can make ping to gmail-smtp-in.l.google.com I don´t have block gmail/webmail.

What else


(Markus Neuberger) #7

Did you try to change the port of your smarthost from 25 to 465 or 587?


(Christian Plaza) #8

where is that… I´m sorry…


(Markus Neuberger) #9

No problem, it’s in the menu under configuration / email / tab smarthost


(Christian Plaza) #10

One question I need to have a domain or no is importan???


(Markus Neuberger) #11

A domain makes mailing much easier. Without domain and MX record you’ll end up using popconnector and smarthost which has some disadvantages and is not recommended. You may try using some dynamic dns service like https://www.dynu.com/ to get a domain with MX record for free but maybe some spamfilters already reject or mark mails from known dyndns IPs.

Here are the docs about how mailing works, what an MX record is etc.

http://docs.nethserver.org/en/v7/mail.html
http://docs.nethserver.org/en/v7/pop3_connector.html


(Michael Träumner) #12

Like @mrmarkuz said port 465 with with SSL should be the right way and I think you have to allow less secure apps as google.

https://support.google.com/accounts/answer/6010255?hl=en