How to reverse these commands for ftp users type system

Greetings i think i made a mistake with these commands having issues with permissions and ftp on the webserver side got confused and ran this command below

config setprop vsftpd UserType system
signal-event nethserver-vsftpd-save

Basically the commands above did not do what i wanted now I am seeking documentation on how to reverse this command string so far have not found any info… I just want to return it back to default if possible…

After that change you are getting this error on ftp login?

530 Permission denied.
Login failed.

After enabling system users, all virtual users are disabled.

By default UserType is set to virtual:

config setprop vsftpd UserType virtual
signal-event nethserver-vsftpd-save


1 Like

Ok so you can see both screens here for some reason ftp doesn’t have access to this folder to i need to chown the folder ftpusername:apache ?

Confused a little as to why it didn’t have write permissions…!Ann6Dvc7oI7enHlZ0HfalSmJZr17

I guess you can do with:

chown apache:ftp -R yourfolder

In this particular case yourfolder can be Packages or any other folder that needs write access from the SMF backend.

That part is still not working… Got me curious if its not the username of the ftp account that it has to be owned by…

You might be right and the ftp account should have permissions over the files, either as owner or as a group member.
I have not much experience with this setup, so I think there are other members who can give you better advice. :slight_smile: