How to reverse proxy cockpit to domain name to access server from everywhere

I want to reverse proxy the cockpit application itself to a domain name so fo example i want to forward localhost:9090 to
I tried to do this with reverse proxy with the name and de target url: http://localhost:9090 but this redirects me to the default page of the webserver how do i fix this?

You can have access to cockpit from everywhere on port 9090 without need of a reverse proxy.

You need https://localhost:9090. Did you enable websocket in proxy advanced settings?

It’s not fully working this way, I can login but parts are not there. Here are instructions how to proxy cockpit with apache but I didn’t test.

If you just need it to change passwords, there are the user settings, it is reachable on default https port.

Where can i find the proxy advanced settings so i can enable websocket?
I guess it is no enabled since i dont know where i can find it

In the reverse proxy settings (or when you create one):

This does not really work so you need to configure manually:

i tried the tutorial you gave me but i cannot make it work i also cannot connect to the server from <public_ip>:9090

Hm, did you grant access from WAN in System/Settings?

1 Like

i added the ip of my laptop which i use to control the interface and my public ip

i fixed this issue since i forgot to switch to wan instead of lan but now when i connect to i can login but when logged in i get a white screen

@gerrietech could you please check permissions for your vhost file?


i completely reinstalled nethserver and then added a reverse proxy to localhost:9090 and just enabled all the options in the add reverse proxy menu but now got the problem that the content is blocked how do i fix this?