How to change default Mail address for ldap users

mailserver
mail
v7

(Inoutchina) #1

NethServer Version: 7.3.1611
Module: Mail LDAP

Hi there,

I setup a mail server with ldap (domain1.com) user authentication. The problem is that my ldap domain is different than from the mail addresse (multiple) that will be associated with the users. I have some users that will use domain2.com as default and others domain3.com. Domain1.com will only be used for the ldap login.
If I create a user the default address from which the user sends mails is now user@domain1.com. But I would like to tell them that some user send mails default with @domain2.com or domain3.com. I know I can handle that with identities but that means I have to manually setup each and every client for all users. Is there a way to set this on the server?

Thank you for the help.

Best regards
Dan


(Giacomo Sanchietti) #2

The mail field inside LDAP is used only from web client like roundcube.
You can’t force the sender server-side.

Still, you can change the mail attribute using ldapmodify command or a LDAP web interface.


(Inoutchina) #3

Hi there,

Thank you for your reply. I have some question regarding your response:

What do you mean by the LDAP web interface? Do I need to install another LDAP gui? I didn’t find any settings in the user management panel to set a mail attribute. Unless I misunderstood something (or looked at the wrong places).

I am aware that I can set this on the client (roundcube) via identities. However, there I have the problem that I need to set up every client from every user individually. Some of them use IMAP combined with Mail Software such as thunderbird or emclient. I need to set it on the server side otherwise there is no end to administration of all those devices (mobiles, pc’s, tablets,…).

Cheers
Dan


(Giacomo Sanchietti) #5

You can use any tool which let you modify the LDAP, like command line tool ldapmodify.
Or a web interface like https://www.ldap-account-manager.org/lamcms/ (see also the howto for NethServer)

The identity must be set on the client, there is no other way (at least I don’t know it).
If there is better solution, I bet @davidep or @filippo_carletti will drop it here :wink: