How do I reset Mattermost?

NethServer Version: 7.8.2003
Module: Mattermost
I installed Mattermost when I setup the server just to test it and now when I decided to start using it I have forgot the passwords :blush:. There is nothing important on the installation so I am perfectly fine with doing a full reset if that is required. When I uninstalled it and installed again all the old data and passwords where kept so I am a bit stuck now.

The postgres database is still there, you need to remove it first to reset mattermost:

Stop mattermost:

systemctl stop mattermost

Enter postgres94 psql:

su - postgres -c "scl enable rh-postgresql94 -- psql --port=55432"

Drop database:

drop database mattermost;

Exit psql:


Reconfigure Mattermost:

signal-event nethserver-mattermost-update


Unfortunately doesn’t that seem to help. I’ve both followed your instruction and tested by uninstalling and install mattermost again after dropping the database but I still get to the login page and it shows the same statistics as earlier.
Is there any other way to gain access? The password reset feature doesn’t work for me, if I use the internal email for my AD account it says a mail has been sent but the inbox remains empty and for my real email it says “Failed to send password reset email successfully.”

There’s no need to uninstall/reinstall.

I forgot to write that one needs to exit from psql before executing signal-event nethserver-mattermost-update. I updated my previous post, so it should work now.

That part I figured out, the problem was that I missed to add the semicolon when dropping the database, blame it on not being used to postgres. Thanks you for all the help, this is by far the best community I am a member of which makes Nethserver one of the best products that I use because I never get the feeling that I am on my own.



I want to reset mattermost password. Also please help me to find default admin user.
i followed document but i am getting following an error.

Screenshot 2021-01-27 at 6.00.12 PM

You need to change the port to 55434 for postgresql 12:

su - postgres -c "scl enable rh-postgresql12 -- psql --port=55434"

Hi i have checked 5432 port also but no luck.

Screenshot 2021-01-27 at 6.12.08 PM

No, you need to use port 55434, not 5432.

Yes i have used ! but not working.

Pls refer screenshot.

why psql not working.

Screenshot 2021-01-27 at 6.12.08 PM

Please enter the complete line instead of only su - postgres:

su - postgres -c "scl enable rh-postgresql12 -- psql --port=55434"

Thanks a lot.

its solved !

1 Like