How do I access servers for speedtest-cli?

I followed the discussion on the innacuracy of Speedtest, but I found it very useful to provide feedback to my ISP (Comcast, in the US) when my connection was slow. Here is why: My cable modem and Nethserver are installed in a closet, and all of my computers are on the LAN side of Nethserver. The Comcast techs insist on a direct connection speed test to the modem, so running Speedtest on Nethserver saves me from unplugging things and hooking a laptop directly too it. I appreciated this when it was available through the Nethserver UI, and still use it through the command line interface. But since I live in California, I want to use a local server. I used to be able to specify server numbers from the database, about a year ago, it worked, but since, when I retrieve the list of servers now, it only lists 11 different ones, and all are in Netherlands or Germany. If i explicitly specify a different server using the --server XXXXX argument, it doesn’t find them. What do I need to do to enable my speedtest installation to access other servers? Is it possible I am blocking port 8080 with Nethserver? Here is what it returns:
[root@tashi ~]# speedtest-cli --list
Retrieving configuration…
35383) CheeseHosting (Dronten, Netherlands) [8824.57 km]
41001) Voiped Telecom (Borger, Netherlands) [8835.99 km]
10644) Jonaz B.V. (Amersfoort, Netherlands) [8842.99 km]
32645) VodafoneZiggo (Arnhem, Netherlands) [8880.51 km]
39965) Daxis-ICT (Enschede, Netherlands) [8901.77 km]
47286) FlawCra (Krefeld, Germany) [8964.74 km]
5835) KomMITT Ratingen (Ratingen, Germany) [8979.97 km]
33397) PHILUNET GmbH (Dusseldorf, Germany) [8983.65 km]
48091) ThĂĽga SmartService (Dusseldorf, Germany) [8983.65 km]
51708) ITbyHF / Alec H. (Dusseldorf, Germany) [8983.65 km]

1 Like

You can use the original speedtest CLI utility from ookla. The one shipped with nethserver is an opensource one (there was some discussion about using or not using the one from ookla due to its license).

Maybe that’s why the list is limited to 10 entries.

EDIT: here’s another person with the same case. It seems related to a change in the speedtest API:


Thank you for responding. The installation from Ookla fails. It looks like it is because Nethserver reports OS type as nethserver/7. I will see

[root@tashi ~]# curl -s | sudo bash
Detected operating system as nethserver/7.
Checking for curl…
Detected curl…
Downloading repository file:
curl: (22) The requested URL returned error: 404 Not Found

Unable to download repo config from:

This usually happens if your operating system is not supported by, or this script’s OS detection failed.

You can override the OS detection by setting os= and dist= prior to running this script.
You can find a list of supported OSes and distributions on our website: packagecloud Documentation - Documentation for the Command-Line Interface (CLI) and automation tools

For example, to force CentOS 6: os=el dist=6 ./

If you are running a supported OS, please email and report this.

Got it working by following instructions here: packagecloud Documentation - Documentation for the Command-Line Interface (CLI) and automation tools

1 Like

I am adding on a note about a different issue i encountered, because I suspect something in the installation procedure for Speedtest messed up Cockpit. The Cockpit interface on port 9090 stopped working after installing the Ookla speedtest package, bu I don’t know why. The old Server Manager UI on port 980 worked fine. I ended up following most of the instructions in this discussion, reinstalling Cockpit. This discussion zeroed in ont a [possibly failing Ethernet NIC, but in my case, I did not make any config changes or disconnect any cables: Cannot access cockpit Web UI (port 9090)

I copied the script from the website for a CentOS installation. For Nethserver, as I stated, you have to specify the OS and distribution. The exact commands needed
with the curl command and OS set to Enterprise Linux, and Dist=7 are at the end of this post. I have a full plate so won’t spend the time to make a Wiki, but if somebody wants to, do so, feel free to use this info.

Also, I have Nethserver installed on a small fanless system manufactured by Qotom, a Chinese company, that has an INtel i7 4600 CPU with 4 cores, and two built-in Realtek RTL8111E Gigabit Ethernet controllers, and a Fenvi 2.5GbE USB adapter, which has a RealTek chip. This USB adapter worked by just plugging it in, and I made no config changes. I am using this with a Technicolor-manufactured Cable Modem router model XB7, branded by Xfinity. This modem has a 2.5G Ethernet port, which is connected to the Qoton system.

My Xfinity service is nominally 1Gbps download, and 20mbps upload.

Running Speedtest from command line on the Netserver system routinely measures greater than 900 Mbps download, with a peak of about 1050 Mbps (even while running a video streams on two Rokus while testing)

this command set will install speedtest on Nethserver 7

If migrating from prior bintray install instructions please first…

sudo rm /etc/yum.repos.d/bintray-ookla-rhel.repo
sudo yum remove speedtest

Other non-official binaries will conflict with Speedtest CLI

Example how to remove using yum

rpm -qa | grep speedtest | xargs -I {} sudo yum -y remove {}
curl -s | sudo os=el dist=7 bash
sudo yum install speedtest

Some interloper wrote to this thread who was suspended for SPAM, but since they raised an issue claiming the CLI speedtest uses one server, and the portal uses more than one, I can report the following:

My config:

Service is rated at 1000 Mbps (1G) download, 20 Mbps upload.

My Xfinity router (vendor is Technicolor France) tests 1140 Mbps download, 23.5 Mb[s upload

The router is connected via 2.5GE to a NethServer gateway, using a small fanless Intel 4th gen i7, with a RealTek 2.5G Ethernet adapter.

I have a desktop with GE NIC running Windows 11, connected to the NethServer through a couple of GE switches, and one link is an RG6 coax cable with two DOCA connecters. DOCA connectors are rated at 2.5G, but both ends are connected to GE switches, so they run at GE.

I get typical results

  1. (I don’t know if this test uses Speedtest or something else) from my Xfinity-branded Technicolor (France) router, configured as a router (not a bridge), accessible from the Xfinity Android app, but I got 1140 Mbps down, 23,5 Mbps up
  2. From NethServer Speedtest-CLI, I got 1040 Mbps down, and 23.5 Mbps up.
  3. From Windows 11 PC with GE adapter, I get 950 Mbps down, and 23.5 Gbps up.