How can i Improve the load Time of Webtop5


(Nitram Oneito) #1

I have noticed that, everytime I launch webtop, immediately after setting the username an dpassowrd,
It takes a while to load. how can I improve on that. load time.


(Giacomo Sanchietti) #2

Please, see my answer here: Nethserver Memory Usage


(Nitram Oneito) #3

bringing this issue back to the surface, @giacomo I upgraded my server resources in terms of resources. it has a RAM of 8 GB and most of the tme the RAM usage is below 4 GB, but while loading webtop, especially for the first time after entering username and password, the loder takes way long a time to bring me the mail interface.

I am not sure wht might be causing the issue. everything else on the server works on. no lags or anything… even webtop after login works flawlessly,
@robb might you have experience a similar situation


(Giacomo Sanchietti) #4

The JVM is really slow on the initializing phase, but it should happen only once.

I don’t know more on WebTop internals.
@webtop_team do you know any tricks about how to profile this thing?


(Nitram Oneito) #5

no one has a solution for the mentioned issue?
or am I the only one experiencing the matter


(Markus Neuberger) #6

How long does the login take? I have to wait about 5 seconds after login (~ 7000 mails) which is quite ok IMO.
I am afraid that loading a lot into memory after login is already the solution to make webtop fast.
You may get used to keep logged in.


(gabriele_bulfon) #7

What browser are you using?
Are you sure it’s a server problem and not the client slowing down download of all the needed js files?
Check with the chrome debugger to see what happens in the network tab, what is taking long.

About the server side, java startup is not your problem, as the web application should be up and running when you arive at login.
Maybe you can check the tomcat startup options (ask the neth guys for directions), so you can set the minimum and maximum memory the JavaVM : 1GB min and 2GB max should be enough for large installations.

On our multitenant cloud infrastructure, one JVM with 3GB max can run 5 separate webtop webapp instances, with a total of some hundreds of users working all day long.

Gabriele


(Nitram Oneito) #8

after reaching the login page, it takes 55 seconds on Microsoft Edge 53 seconds on Mozilla firefox, and 57 seconds on chrome. to load the mails ui,
I have 300 mails…

its a challenge I seem to get only with webtop, and only during the login process, after login all is well. The proble is I can not set it to remain logged in, as I get logged out after some time.


(Dan) #9

…and lest you think @oneitonitram’s case is unique, it took 78 seconds for me to log in to my “home” screen just a moment ago. That’s using a reasonably well-resourced VPS, though it remote to me. Firefox on Windows.


(Markus Neuberger) #10

OK that’s quite a long time to wait, I tried on 2 webtop servers, login time 5 - 10 seconds in Firefox on Windows. What could be the problem here?

Is there some information in the logfile /var/log/webtop/webtop.log ?

Was it that slow after install?

Did you already try some memory tweaks as @gabriele_bulfon supposed?

config setprop webtop MaxMemory 2048
signal-event nethserver-webtop5-update

Maybe some module makes problems here? Just to compare with a machine with fast working login:

rpm -qa "nethserver-*" | sort

Installed rpms on my server with fast login webtop instance:

[root@server2 ~]# rpm -qa “nethserver-*” | sort
nethserver-antivirus-1.2.1-1.ns7.noarch
nethserver-automx-0.0.1-5.ns7.noarch
nethserver-avahi-1.1.0-1.ns7.noarch
nethserver-awstats-0.1.5-1.ns7.sdl.noarch
nethserver-backup-config-2.2.1-1.ns7.noarch
nethserver-backup-data-1.4.1-1.ns7.noarch
nethserver-base-3.5.0-1.ns7.noarch
nethserver-cgp-2.1.3-1.ns7.noarch
nethserver-collectd-3.0.7-1.ns7.noarch
nethserver-crontabmanager-0.1.1-1.ns7.sdl.noarch
nethserver-cups-1.2.1-1.ns7.noarch
nethserver-danb35-1.0.0-2.el7.noarch
nethserver-dc-1.5.6-1.ns7.x86_64
nethserver-diagtools-1.0.2-1.ns7.noarch
nethserver-dnsmasq-1.6.6-1.ns7.noarch
nethserver-dokuwiki-1.2.6-1.ns7.sdl.noarch
nethserver-duc-1.4.5-1.ns7.noarch
nethserver-ejabberd-1.3.1-1.ns7.noarch
nethserver-fail2ban-1.0.7-1.ns7.noarch
nethserver-firewall-base-3.4.2-1.ns7.noarch
nethserver-guacamole-0.0.0-3.ns7.noarch
nethserver-horde-0.0.1-1.18.g449b985.ns7.noarch
nethserver-hosts-1.2.2-1.ns7.noarch
nethserver-httpd-3.2.7-1.ns7.noarch
nethserver-httpd-admin-2.3.4-1.ns7.noarch
nethserver-httpd-proxypass-3.2.7-1.ns7.noarch
nethserver-httpd-virtualhosts-3.2.7-1.ns7.noarch
nethserver-lang-en-1.2.15-1.ns7.noarch
nethserver-letsencrypt-1.1.6-1.ns7.noarch
nethserver-lib-2.2.8-1.ns7.noarch
nethserver-lsm-1.2.3-1.ns7.noarch
nethserver-mail-common-2.3.0-1.ns7.noarch
nethserver-mail-filter-2.3.0-1.ns7.noarch
nethserver-mail-getmail-2.3.0-1.ns7.noarch
nethserver-mail-quarantine-2.3.0-1.12.pr83.g5a4f6f5.ns7.noarch
nethserver-mail-server-2.3.0-1.ns7.noarch
nethserver-mail-smarthost-2.3.0-1.ns7.noarch
nethserver-mattermost-1.1.2-1.ns7.x86_64
nethserver-memcached-1.1.0-1.ns7.noarch
nethserver-mrmarkuz-0.0.1-2.ns7.noarch
nethserver-mysql-1.1.3-1.ns7.noarch
nethserver-nethforge-release-7-2.ns7.noarch
nethserver-net-snmp-1.1.0-1.ns7.noarch
nethserver-nextcloud-1.2.6-1.ns7.noarch
nethserver-nginx-0.0.1-1.ns7.noarch
nethserver-ntp-1.1.3-1.ns7.noarch
nethserver-omd-0.0.1-4.ns7.noarch
nethserver-onlyoffice-0.0.1-4.ns7.noarch
nethserver-openssh-1.2.2-1.ns7.noarch
nethserver-phonehome-1.3.0-1.ns7.noarch
nethserver-php-1.2.0-1.ns7.noarch
nethserver-phpldapadmin-0.0.5-1.ns7.sdl.noarch
nethserver-phpmyadmin-1.2.2-1.ns7.sdl.noarch
nethserver-php-scl-1.2.4-1.ns7.sdl.x86_64
nethserver-phpsettings-1.1.2-1.ns7.sdl.noarch
nethserver-postgresql-1.1.0-1.ns7.noarch
nethserver-postgresql94-1.0.0-1.ns7.noarch
nethserver-redis-1.1.0-1.ns7.noarch
nethserver-release-7-8.ns7.noarch
nethserver-restore-data-1.2.5-1.ns7.noarch
nethserver-rh-php56-php-fpm-1.0.0-1.ns7.noarch
nethserver-rh-php71-php-fpm-1.0.0-1.3.g395a32c.ns7.noarch
nethserver-roundcubemail-1.2.10-1.ns7.noarch
nethserver-samba-4.1.0-1.ns7.noarch
nethserver-samba-audit-1.1.5-1.ns7.noarch
nethserver-sambastatus-7.0-2.x86_64
nethserver-smartd-1.1.0-1.ns7.noarch
nethserver-sogo-1.7.7-1.ns7.noarch
nethserver-sssd-1.4.2-1.ns7.noarch
nethserver-stephdl-1.0.7-1.ns7.sdl.noarch
nethserver-subscription-3.1.2-1.ns7.noarch
nethserver-subscription-ui-3.1.2-1.ns7.noarch
nethserver-tomcat-1.1.0-1.ns7.noarch
nethserver-unbound-1.1.0-1.ns7.noarch
nethserver-vsftpd-1.1.1-1.ns7.noarch
nethserver-webtop5-1.2.8-1.ns7.noarch
nethserver-yum-1.4.1-1.ns7.noarch

Maybe it is about java version?

[root@server2 ~]# java -version
openjdk version "1.8.0_181"
OpenJDK Runtime Environment (build 1.8.0_181-b13)
OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)

(Nitram Oneito) #11

I have updated webtop max memory to 4096 since I have a lot.
I have the same java version, and my server is up to date.
here is the nethserver rpm

Edit: setting it to 4096 takes even way longer to load, I reset it to 2048

[root@my ~]# rpm -qa “nethserver-*” | sort
nethserver-antivirus-1.2.1-1.ns7.noarch
nethserver-backup-config-2.2.1-1.ns7.noarch
nethserver-backup-data-1.4.1-1.ns7.noarch
nethserver-base-3.5.0-1.ns7.noarch
nethserver-cgp-2.1.3-1.ns7.noarch
nethserver-collectd-3.0.7-1.ns7.noarch
nethserver-diagtools-1.0.2-1.ns7.noarch
nethserver-directory-3.3.0-1.ns7.noarch
nethserver-dnsmasq-1.6.6-1.ns7.noarch
nethserver-duc-1.4.5-1.ns7.noarch
nethserver-ejabberd-1.3.1-1.ns7.noarch
nethserver-fail2ban-1.0.7-1.ns7.noarch
nethserver-firewall-base-3.4.2-1.ns7.noarch
nethserver-firewall-base-ui-3.4.2-1.ns7.noarch
nethserver-hosts-1.2.2-1.ns7.noarch
nethserver-httpd-3.2.7-1.ns7.noarch
nethserver-httpd-admin-2.3.4-1.ns7.noarch
nethserver-httpd-proxypass-3.2.7-1.ns7.noarch
nethserver-httpd-virtualhosts-3.2.7-1.ns7.noarch
nethserver-lang-en-1.2.15-1.ns7.noarch
nethserver-letsencrypt-1.1.6-1.ns7.noarch
nethserver-lib-2.2.8-1.ns7.noarch
nethserver-lsm-1.2.3-1.ns7.noarch
nethserver-mail-common-2.3.0-1.ns7.noarch
nethserver-mail-disclaimer-2.3.0-1.ns7.noarch
nethserver-mail-filter-2.3.0-1.ns7.noarch
nethserver-mail-getmail-2.3.0-1.ns7.noarch
nethserver-mail-p3scan-2.3.0-1.ns7.noarch
nethserver-mail-server-2.3.0-1.ns7.noarch
nethserver-mail-smarthost-2.3.0-1.ns7.noarch
nethserver-mrmarkuz-0.0.1-2.ns7.noarch
nethserver-mysql-1.1.3-1.ns7.noarch
nethserver-nethforge-release-7-2.ns7.noarch
nethserver-nextcloud-1.2.6-1.ns7.noarch
nethserver-nginx-0.0.1-1.ns7.noarch
nethserver-ntp-1.1.3-1.ns7.noarch
nethserver-onlyoffice-0.0.1-4.ns7.noarch
nethserver-openssh-1.2.2-1.ns7.noarch
nethserver-phonehome-1.3.0-1.ns7.noarch
nethserver-php-1.2.0-1.ns7.noarch
nethserver-postgresql-1.1.0-1.ns7.noarch
nethserver-redis-1.1.0-1.ns7.noarch
nethserver-release-7-8.ns7.noarch
nethserver-restore-data-1.2.5-1.ns7.noarch
nethserver-rh-php56-php-fpm-1.0.0-1.ns7.noarch
nethserver-rh-php71-php-fpm-1.0.0-1.ns7.noarch
nethserver-smartd-1.1.0-1.ns7.noarch
nethserver-sssd-1.4.2-1.ns7.noarch
nethserver-subscription-3.1.2-1.ns7.noarch
nethserver-subscription-ui-3.1.2-1.ns7.noarch
nethserver-unbound-1.1.0-1.ns7.noarch
nethserver-vsftpd-1.1.1-1.ns7.noarch
nethserver-webtop5-1.2.8-1.ns7.noarch
nethserver-yum-1.4.1-1.ns7.noarch


(Markus Neuberger) #12

Do you have some integrations active like cloud or chat?

Do you use webtop for calendar and contacts via mobile phone client?


(Nitram Oneito) #13

currently I have nextcloud activated, as well as chat on the webtop.

I don’t think the above mentioned might be the issues causing the delays, because the delays were there even before I activated the function.

logs, recent

java.lang.InterruptedException: sleep interrupted
at java.lang.Thread.sleep(Native Method)
at com.sonicle.webtop.mail.MailFoldersThread.run(MailFoldersThread.java:128)
2018-10-16 20:56:52 [ERROR] com.sonicle.webtop.mail.Service - Exception
java.lang.InterruptedException: sleep interrupted
at java.lang.Thread.sleep(Native Method)
at com.sonicle.webtop.mail.MailFoldersThread.run(MailFoldersThread.java:128)
2018-10-16 21:02:46 [ERROR] com.sonicle.webtop.mail.Service - Exception
java.lang.InterruptedException: sleep interrupted
at java.lang.Thread.sleep(Native Method)
at com.sonicle.webtop.mail.MailFoldersThread.run(MailFoldersThread.java:128)
2018-10-16 22:49:58 [ERROR] com.sonicle.webtop.mail.Service - Exception
java.lang.InterruptedException: sleep interrupted
at java.lang.Thread.sleep(Native Method)
at com.sonicle.webtop.mail.MailFoldersThread.run(MailFoldersThread.java:128)
2018-10-18 07:03:33 [ERROR] com.sonicle.webtop.mail.Service - Exception
java.lang.InterruptedException: sleep interrupted
at java.lang.Thread.sleep(Native Method)
at com.sonicle.webtop.mail.MailFoldersThread.run(MailFoldersThread.java:128)


(Giacomo Sanchietti) #14

It’s probably something due to IMAP access.
When the page is slowly starting, does the use of dovecot CPU increase?

Do you have the same issue when using roundcube?


(Nitram Oneito) #15

when using roundcube and rainloop, or even sogo, none of the delays are experienced.
I love to use webtop because it looks great and works greta, but the loading time takes way too long on webtop


(gabriele_bulfon) #16

Ok, can you give us a test WebTop user access to your system so we can start checking ourselves what happens client-side?

Gabriele


(Nitram Oneito) #17

sorry for delayed response…

make use of this test user
address: my.genius.ke/webtop
username: kelvin
password: N3thte$t


(Nitram Oneito) #18

@gabriele_bulfon did you have a look?
Edit: I have just installed sogo incase you need to do a comparison


(gabriele_bulfon) #19

logs in very quickly, few seconds and you’re in, from here.


(Nitram Oneito) #20

ok, thats a new one. could it be a latency issue or something cause am not getting…