Hotsync / stunnelservice doesn't start after update and reboot

v7
hotsync

(Ralf Jeckel) #1

NethServer Version: 7.5.1804 subscritpion
Module: Hotsync

Hi friends,

I’ve a problem with my productionsystem. After last update and reboot stunnel-service and so hotsync doesn’t work anymore.

from boot.log:

[e[1;39m INFO e[0m] Network Manager is not active.
[e[1;33mDEPENDe[0m] Dependency failed for Network Manager Wait Online.
.
.
.
[e[1;31mFAILEDe[0m] Failed to start Stunnel daemon.
See 'systemctl status stunnel.service' for details.

.

[root@nethserver ~]# systemctl status stunnel                                                                                                                  
● stunnel.service - Stunnel daemon
   Loaded: loaded (/usr/lib/systemd/system/stunnel.service; enabled; vendor preset: disabled)                                                                  
   Active: failed (Result: start-limit) since Thu 2018-10-11 12:39:08 CEST; 27min ago
     Docs: man:stunnel(8)                                                                                                                                      
  Process: 4760 ExecStart=/usr/bin/stunnel /etc/stunnel/stunnel.conf (code=exited, status=1/FAILURE)
                                                                                                                                                               
Oct 11 12:39:08 nethserver.jeckel.local stunnel[4760]: Service [rsync] closed                                                                                  
Oct 11 12:39:08 nethserver.jeckel.local stunnel[4760]: str_stats: 11 block(s), 1065 data byte(s), 638 control byte(s)                                          
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: Failed to start Stunnel daemon.
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: Unit stunnel.service entered failed state.                                                                 
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: stunnel.service failed.                                                                                    
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: stunnel.service holdoff time over, scheduling restart.                                                     
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: start request repeated too quickly for stunnel.service                                                     
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: Failed to start Stunnel daemon.
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: Unit stunnel.service entered failed state.                                                                 
Oct 11 12:39:08 nethserver.jeckel.local systemd[1]: stunnel.service failed.           

.

 [root@nethserver ~]# config show hotsync                                                                                                                       
 hotsync=configuration                                                                                                                                          
 MasterHost=192.168.0.230                                                                                                                                   
 SlaveHost=192.168.0.234                                                                                                                                    
 SlavePort=273                                                                                                                                              
 databases=enabled                                                                                                                                          
 role=master                                                                                                                                                
 status=enabled            

.
rsyncd is running. lsm not active, because only one ISP.

Has somone any advice for me?

TIA Ralf

EDIT: Just tried signal-event nethserver-hotsync-save and now stunnel is running and rsyncd is deactivated. Is this correct?

But why doesn’t it start at boot?


(Ralf Jeckel) #2

I mark this topic as solved, as the slave receives constantly every 15 minutes data from rsync and the problem seems to be solved by the signal-event command.