HotSync error: rsync returned 2

NethServer Version: 7.9.2009
Module: HotSync v2.2.4

Hi everyone!

I recently started getting error emails from my server regarding the HotSync module.
It stops with the following error message:

hotsync error: rsync returned 2. rsync output:
ERROR: rejecting excluded file-list name: var/lib/nethserver/secrets
rsync error: protocol incompatibility (code 2) at flist.c(907) [receiver=3.1.2]
rsync error: protocol incompatibility (code 2) at io.c(1640) [generator=3.1.2]

I get these messages every 15 minutes.

It started last week when I had problems running yum update because it had problems with php-gd which I solved by installing php-gd from REMI’s repo and remi-php7.2. After that, I could update the system so now it’s fully updated.

Tried reinstalling the module, but no luck. Didn’t want to start messing with rsync because many emails are not synced with the slave server, so I didn’t want to break the system.

Can anyone suggest a way to solve this problem?
Thank you in advance!

EDIT: Spelling

you can try downgrading rsync to check if it works, or wait for next rsync update. 2123815 – rsync error: protocol incompatibility when using rsync-3.1.2-11.el7_9

Unfortunately the older rsync-3.1.2-10.el7_9.x86_64 doesn’t work. I get the same error.
I used yum downgrade rsync, it showed that rsync-3.1.2-11.el7_9.x86_64 will go back to rsync-3.1.2-10.el7_9.x86_64 but still no luck.

Then I guess I have to wait for the next release, thanks anyway!

So I somehow managed to solve it or at least I can see my emails up to date on the salve server, so I think, hotsync is working again.

I temporary disabled automatic updates as it updated rsync to rsync-3.1.2-11.el7_9.x86_64 on both servers again overnight. I downgraded them again, restarted both servers as it had problems starting rsyncd service and it worked. Had some side effects like not seeing my mailbox in SOGo after login but after a few forced hostync commands, it seems to be working now. :+1:

Side note: It would be nice if I got a notification or a message on the terminal at the end of the hotsync command to see if it was successful. Currently it shows me that the backup was successful but that’s it.

1 Like