Home Directory mounts via nfs


(Ralph) #1

Hi,

our linux clients mount the home directory as nfs share from the NS PDC to /srv/home with a symlink to /var/lib/nethserver/home. In general it work. But when I run a sudo command like “sudo mc” in a terminal on the linux client, I get error messages like "cannot create /var/lib/nethserver/home/user/.cache/mc. This directory exists though. So it has to do with permissions.
Can anybody explain what goes wrong here? Would it be better to use mount --bind instead of the symlink?

Thanks for hints.
Ralph


(Bogdan Costin) #2

Hi Ralph,
Indeed it is better to use mount with bind instead of a symlink.
Mounting the home via NFS can pose some problems. It is advisable to check the configuration of the nfs server. Maybe the nolock option could help.


(Ralph) #3

Has anybody else joined a linux workstation to the NS PDC? If so, how do you provide the home directory of the user? I tried pam_mount instead of nfs but no success.


(Bogdan Costin) #4

Hi Ralph, not yet. It is still work in progress… :slight_smile: I’ve tried something but did not yet succeeded.
I’m also very interested in this subject, maybe somebody with a success story can join the discussion ? :smile:


(Giacomo Sanchietti) #5

Never tried, but you can look to FreeIPA docs for some tips (?): https://docs.fedoraproject.org/en-US/Fedora/15/html/FreeIPA_Guide/users.html#home-directories


(Bogdan Costin) #6

Thanx @giacomo, I was using the ubuntu docs since I use Linux Mint. The only working configuration was to use automount.xml in the home folder but this did not solve the issue to mount home folder of the user into the system at logon.
I’ll keep digging and see what can be done (when time permits :frowning: )