HELP - SAMBA DC crashed by its own stupidity

I’ve shot my DC!

I wanted to test something in the area of networks and went to nothing more!

Currently I have no Samba DC to run, and the brigde is gone!
That is, I have a physical red and green interface, but no users or groups more!

I can not create a new brigade in the menu, no hook is settable. In the user area, no DC controller is active! …

What can I do?


How to reset the DC?

In the GUI gehts unfortunately not, I have now a werkreset according to the instructions, but it does not work.
I created the brigade.

Otherwise, I have to rebuild everything tomorrow!

to fully reset… which means you’ll have to rebuild…

or, more options for repair

Thanks, exactly this statement I’ve already worked through it, it comes then the message:

Configure Samba Active Directory
The Domain Controller (DC) container must be configured before being started

However, I can not make below details, all input fields are gray background …

[root@openzwo ~]# config show nsdc
[root@openzwo ~]#

most of that is from worked from the, preferably, console or shell.

You could create a green bridge with “new logical interface” button to restore br0.

Brigde I have created but no change, unfortunately …

Property after the creation of the brigade, still a DC Factory reset.
Unfortunately nothing

irgendwo hat er noch alte Daten gefunden nur wo?

habe jetzt zweimal einen Factory Reset gemacht :frowning:

1 Like

Could you find anything relevant in system logs?

NSDC is running
SSSD is not running

Which log should I look at the best?


(Mon Jan 16 22:34:01:345984 2017) [sssd] [sss_ini_get_config] (0x0010): Failed to parse configuration. Error 5. (Mon Jan 16 22:34:01:361247 2017) [sssd] [sss_ini_get_config] (0x0010): Errors detected while parsing: /etc/sssd/sssd.conf (Mon Jan 16 22:34:01:361464 2017) [sssd] [sss_ini_config_print_errors] (0x0010): Error (8) on line 1: Failed to read line. (Mon Jan 16 22:34:01:361513 2017) [sssd] [confdb_init_db] (0x0010): Failed to load configuration (Mon Jan 16 22:34:01:361579 2017) [sssd] [confdb_setup] (0x0010): ConfDB initialization has failed [5]: Input/output error (Mon Jan 16 22:34:01:361666 2017) [sssd] [load_configuration] (0x0010): Unable to setup ConfDB [5]: Input/output error (Mon Jan 16 22:34:01:361698 2017) [sssd] [main] (0x0020): SSSD couldn't load the configuration database.

sssd.conf in etc is empty

This is a consequence of the factory reset.

Try with:

 signal-event nethserver-sssd-save

…and see the logs

So, I now have the NS7 reinstalled.

Thanks, all who helped me!
@davidep , @fasttech


Hi, I’m new on this forum with 2nd post. I also faced problem from this topic. If You made Fatory Reset as mentioned above and You have Start DC unclickable, probably:

config show nsdc

gives You:

then try:
config setprop nsdc status disabled

this will set nsdc status to disabled then new start is possible.
I hope this will help others. Cheers


Please, open a pull request to fix the documentation!

Sorry @dj_marian I directed you to the wrong place! My mistake!

The right documentation file to modify was

Anyway, I finally applied your patch to both files. It’s fine for me! Thank you!

1 Like