Help onlyoffice

v7
nextcloud
onlyoffice

(Axel Urbanski) #21

Hello LayLow

yes i will but yesterday was 2 late i will strart again :slight_smile: this weekend. But TaxOffice is calling 4 papers :frowning:


(Axel Urbanski) #22

Hello Markus

I will try it again 2morrow. So ther is nothing 2 do on the NethserverAdminWebSide?

Weekend :wink: and i try again the Quickinstall again in a XCP-NG VM, and i looks differend to the friest two trys :wink: A lill bit more packages … I am saving the list of packages. Now 2 the Nextcloud config…

I am starting with
config setprop fw_onlyoffice host 1.2.3.4 (with the IP of my Nethserver)

sorry there was something be4
[root@neth ~]# config setprop fw_onlyoffice RejectUnauthorized false
[root@neth ~]# config setprop fw_onlyoffice host 192.168.38.10

I hope was not so bad :frowning:
signal-event nethserver-onlyoffice-update

https://192.168.38.10:8082/welcome/

Document Server is running

same result like the first try :frowning:

Some Logfiles 2morrow … or in the morning


(Markus Neuberger) #23

Please check

  • /var/log/onlyoffice/documentserver/docservice/err.log
  • /var/log/onlyoffice/documentserver/docservice/out.log
  • /var/lib/nethserver/nextcloud/nextcloud.log

(Axel Urbanski) #24

good Morning
a cup of tee and than try again

first the self made cert was changed, must reload it in firefox.

I working strictly with the Quickinstall .
Than
[root@neth ~]# config setprop fw_onlyoffice host 192.168.38.10
[root@neth ~]# config setprop fw_onlyoffice RejectUnauthorized false
[root@neth ~]# config setprop fw_onlyoffice host 192.168.38.10

at the end

https://192.168.38.10:8082
Document Server is running

https://192.168.38.10/nextcloud/index.php/login
I had the Login

But is “fresh” no Users and Groups

/var/log/onlyoffice/documentserver/docservice/err.log is emty

/var/log/onlyoffice/documentserver/docservice/out.log

[2019-01-12T01:02:10.222] [WARN] nodeJS - Plugins watch exception (https://nodejs.org/docs/latest/api/fs.html#fs_availability).
[2019-01-12T01:02:10.326] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:10.538] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:10.882] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:11.468] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:12.453] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:14.134] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:16.987] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:21.831] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:30.044] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:02:44.012] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:03:07.747] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:03:48.095] [ERROR] nodeJS - redisClient error Error: Redis connection to localhost:6379 failed - connect ECONNREFUSED 127.0.0.1:6379
[2019-01-12T01:05:00.020] [WARN] nodeJS - Plugins watch exception (https://nodejs.org/docs/latest/api/fs.html#fs_availability).
[2019-01-12T01:05:00.142] [WARN] nodeJS - update cluster with 1 workers
[2019-01-12T01:05:00.213] [WARN] nodeJS - worker 82624 started.
[2019-01-12T01:05:00.213] [WARN] nodeJS - update cluster with 1 workers
[2019-01-12T01:05:03.404] [WARN] nodeJS - Express server starting...
[2019-01-12T01:05:06.201] [WARN] nodeJS - Express server listening on port 48000 in production-linux mode
[2019-01-12T01:16:44.543] [WARN] nodeJS - Plugins watch exception (https://nodejs.org/docs/latest/api/fs.html#fs_availability).
[2019-01-12T01:16:44.642] [WARN] nodeJS - update cluster with 1 workers
[2019-01-12T01:16:44.691] [WARN] nodeJS - worker 94199 started.
[2019-01-12T01:16:44.692] [WARN] nodeJS - update cluster with 1 workers
[2019-01-12T01:16:47.858] [WARN] nodeJS - Express server starting...
[2019-01-12T01:16:50.641] [WARN] nodeJS - Express server listening on port 48000 in production-linux mode

/var/lib/nethserver/nextcloud/nextcloud.log is emty

[root@neth ~]# cat /etc/nginx/conf.d/onlyofficedocumentserver.conf
cat: /etc/nginx/conf.d/onlyofficedocumentserver.conf: No such file or directory

but /etc/nginx/conf.d/onlyoffice-documentserver.conf is there

## HTTPS host
server {
  listen 0.0.0.0:8082 ssl;
  listen [::]:8082 ssl default_server;

  server_tokens off;
  root /usr/share/nginx/html;

  ## Strong SSL Security
  ## https://raymii.org/s/tutorials/Strong_SSL_Security_On_nginx.html
  ssl on;
  ssl_certificate /etc/pki/tls/certs/localhost.crt;
  ssl_certificate_key /etc/pki/tls/private/localhost.key;
  ssl_verify_client off;

(Markus Neuberger) #25

Does it work now?

The errors and warnings are ok, I have the same on my machine and it’s working.

You may login as Nextcloud admin with username admin and password Nethesis,1234


(Axel Urbanski) #26

NextCloud Log with amin was okay

That is okay and under Nextcloud Apps Onlyoffice is running

https://192.168.38.10:8082/welcome/

This side say : DokumentServer is runnig

That the way 2 get the GUI from Onlyoffice with a login ?


(Markus Neuberger) #27

In Nextcloud you need to open an office document or create one with the “+” button.


(Axel Urbanski) #28

sometime the world is simpel when soboby know how simpel :wink:

on https://neth:8082 is only the status of the Doc-Server :slight_smile:
and open up the Docs directly :slight_smile:

very easy! but 2 easy for a oldfashion IT Guy

the was some missunderstanding like mine in the community :slight_smile:

will be nice when you add a few line in your very good HowToDo

Like the this

First use Onlyoffice

Login in Nextcloud
loadup a document or use Nextcloud -> files -> (+) new Document
Than Nextclout will oben up Onlyoffce with your doc …

THX 4 Help and looks like great work :slight_smile:


(Axel Urbanski) #29

Now with real user test :slight_smile: build user an PW and retry

Internal its running perfect :slight_smile: (local Intranet)


(Axel Urbanski) #30

Now its running :slight_smile: very nice software a a good integration :slight_smile:

My testing Plattform is a XCP_NG 7.6 Server with 16G RAM and a AMD Phenom™ II X4 965 Processor 3.4 GHz.

The VM was running with 4G RAM an 1 CPU. When i am testing one CPU was on 100%, but system was working fine. After reboot CPU was lower. Them I try 2 Cores and 6GRam now both CPUs ar on 40% with OnlyOffice 60%…

But most preformance neeeds Nextcloud…

Thx only a information 4 Users with 100% CPU consumtions. The infos are reading from XCP_NG Host


(Antonio) #31

Hello
Yes or tried with self-signed certificates and without, but the problem remains how can I do to solve the thing where I’m wrong
I have to use it both in Local and in remote


(Markus Neuberger) #32

For using onlyoffice with a self-signed certificate you have to allow the document server page in your browser. (I tested with Firefox)

Browse to https://NETHSERVER:8082 and allow the site in your browser otherwise the documentserver may not work.

The recommended way is to use a letsencrypt cert and always use https://domain.tld/nextcloud instead of a local address, so you don’t have to care about the browser settings.

config setprop fw_onlyoffice RejectUnauthorized ''
config setprop fw_onlyoffice host domain.tld
signal-event nethserver-onlyoffice-update


(Antonio) #33

ok:kissing_heart::heart_eyes::kissing_heart::smiling_face_with_three_hearts: