Help needed with Shared Folders

v7
sharedfolders

(Krishna Kanakapura) #1

NethServer Version: 7.6.1810 (final)
Module: shared folders

I am very new to NethServer and IT in general, also I apologize for the lengthy post.

Setup: I have a nethserver vm, inside a proxmox host. I am passing two network interfaces to the vm. One is being assigned an ip (by dhcp) - this is a red interface inside nethserver. The other one I am assigning a static ip from within nethserver, and its set to be a green interface.

Domain: I have created an active directory domain, with a different ip (this was required to be), and it is up and running .

NetBIOS domain name: XXXXXXXXXXXX

LDAP server: 192.168.xx.xx

LDAP server name: xxxx-xxxxxxxx.xxxxxx.lan

Realm: XXXXXXXXX.XXX

Bind Path: dc=XXXXXXXXX,dc=XXX

LDAP port: 389

Server time: Thu, 14 Mar 2019 10:51:26 EDT

KDC server: 192.168.xx.xx

Server time offset: 0

Last machine account password change: Mon, 11 Mar 2019 13:46:35 EDT

Join is OK

whenCreated: 20190311174635.0Z

name: XXXXXXX

objectSid: S-1-5-21-1343530846-794443157-150560365-1104

accountExpires: 9223372036854775807

sAMAccountName: XXXXXXXXXX$

pwdLastSet: 131967999953904420

dNSHostName: xxxxxxx.xxxxxxxx.xxx

servicePrincipalName: HOST/XXXXXX

servicePrincipalName: HOST/xxxxx.xxxxx.lan

servicePrincipalName: smtp/nethserver

servicePrincipalName: smtp/nethserver.xxxxxxxx.lan

servicePrincipalName: pop/nethserver

servicePrincipalName: pop/nethserver.xxxxx.lan

servicePrincipalName: imap/nethserver

servicePrincipalName: imap/nethserver.xxxxxxx.lan

whenChanged: 20190311174653.0Z

lastLogon: 131970484543334600

distinguishedName: CN=NETHSERVER,CN=Computers,DC=xxxxxx,DC=lan

Problem: In active directory, I have created a few users, and a group that has all users. I have also created a few shared folders. All folders allow guest access, and I have also enabled the browseable option. Inside nethserver, I can see that that smb service is running, and also the relevant ports are open in the firewall.

I ran nmap from an ubuntu container on the domain controller’s ip and it did show the relevant ports open.

According to the documentation, I think the shared folders can be accessed just like samba shares. But when I try to access the shares, using the domain controller’s ip, (in windows) I can see only two shares - netlogon and sysvol.

In windows explorer, when I try to access the domain controller’s ip like \\<ip>\ , it asks me for a username and password, once I enter the credentials, I can see only netlogon and sysvol.

From ubuntu, I tried to use smbclient.

smbclient //<domain controller ip>/characterization -U username -W <WORKGROUP>

I get a warning that “syslog” option is deprecated, and then a password, upon entering the password, I get

tree connect failed: NT_STATUS_BAD_NETWORK_NAME

However, In the same fashion I am able to access netlogon and sysvol, and I can look at the different files in sysvol.

How do I access the shared folders?
I have tried restarting the smb service from the status>>services page, I have tried rebooting the server,etc, but nothing changed the situation.

Please help!!
Any help or suggestion is appreciated.


(HF) #2

Good first post!


(HF) #3

First remark, is this a good idea? DHCP on the RED interface


(Krishna Kanakapura) #4

I am very new to networking, Please correct me if I’m wrong.
If your nethserver is connected to the internet (ethernet to a comcast to verizon router).
It is getting assigned an ip automatically right?
Therefore inside neth I’ve set this interface to red/dhcp.
I thought this was the right course of action, If not please tell me the right method.


(Markus Neuberger) #5

It seems you’ve done a correct installation :clap:

The created shares are not on the domain controller, they are on the Nethserver that acts as domain member.

This should work:

smbclient //<nethserver ip>/characterization -U username -W <WORKGROUP>

This is a local issue on the Ubuntu but does no harm. Try to comment syslog = 0 in /etc/samba/smb.conf (at least for Debian that helped)

I prefer a static IP to avoid DHCP client problems or delays but if you get a dynamic IP from provider you have to get the IP on the red interface by DHCP. That’s fully ok.


(Krishna Kanakapura) #6

@mrmarkuz Thank You Sir !!
You’re right!!

I just typed in \\<nethserver-ip>\ in windows explorer, and I can see my shares and i can access them :sweat_smile: :sweat_smile:

Thank your very much for your help, I was stuck on this for a long time.

Also, Is there any way I can control the ip on which the shares appear.
I mean, can add another interface, give it a static ip and make the shares appear on that ip,


(Markus Neuberger) #7

Glad it works finally. :grinning:

Yes, just add another green interface.


(Krishna Kanakapura) #8

@mrmarkuz Thanks a lot my friend,
Just tried it, That Works !
Thanks again.

Yours Thankfully,
Krishna


(HF) #9

Please mark the answer as solved. Thanks!