Hello i use a small installation of Nethserver and cant update

updates
v7

(Axel Urbanski) #1

NethServer Version: 7.6
Module: SoftwareCenter update

hello
I had a problem with the normal softwareupdate. The softwarecenter says ther are updates. i try it with out sucess.Software Center told me erase the Yum Cache. next try, same results…

If i try yum from the commandline, i get this errormassages.
Dind anybody had a Idea ?

–> Finished Dependency Resolution
Error: Package: 1:npm-3.10.10-1.6.16.0.1.el7.x86_64 (epel)
Requires: nodejs = 1:6.16.0-1.el7
Removing: 1:nodejs-6.14.3-1.el7.x86_64 (@epel)
nodejs = 1:6.14.3-1.el7
Updated By: 2:nodejs-8.15.1-1nodesource.x86_64 (nodesource)
nodejs = 2:8.15.1-1nodesource
Available: 1:nodejs-6.16.0-1.el7.x86_64 (epel)
nodejs = 1:6.16.0-1.el7
Available: 2:nodejs-8.0.0-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.0.0-1nodesource.el7.centos
Available: 2:nodejs-8.1.0-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.1.0-1nodesource.el7.centos
Available: 2:nodejs-8.1.1-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.1.1-1nodesource.el7.centos
Available: 2:nodejs-8.1.2-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.1.2-1nodesource.el7.centos
Available: 2:nodejs-8.1.3-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.1.3-1nodesource.el7.centos
Available: 2:nodejs-8.1.4-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.1.4-1nodesource.el7.centos
Available: 2:nodejs-8.2.0-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.2.0-1nodesource.el7.centos
Available: 2:nodejs-8.2.1-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.2.1-1nodesource.el7.centos
Available: 2:nodejs-8.3.0-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.3.0-1nodesource.el7.centos
Available: 2:nodejs-8.4.0-1nodesource.el7.centos.x86_64 (nodesource)
nodejs = 2:8.4.0-1nodesource.el7.centos
Available: 2:nodejs-8.5.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.5.0-1nodesource
Available: 2:nodejs-8.6.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.6.0-1nodesource
Available: 2:nodejs-8.7.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.7.0-1nodesource
Available: 2:nodejs-8.8.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.8.0-1nodesource
Available: 2:nodejs-8.8.1-1nodesource.x86_64 (nodesource)
nodejs = 2:8.8.1-1nodesource
Available: 2:nodejs-8.9.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.9.0-1nodesource
Available: 2:nodejs-8.9.1-1nodesource.x86_64 (nodesource)
nodejs = 2:8.9.1-1nodesource
Available: 2:nodejs-8.9.2-1nodesource.x86_64 (nodesource)
nodejs = 2:8.9.2-1nodesource
Available: 2:nodejs-8.9.3-1nodesource.x86_64 (nodesource)
nodejs = 2:8.9.3-1nodesource
Available: 2:nodejs-8.9.4-1nodesource.x86_64 (nodesource)
nodejs = 2:8.9.4-1nodesource
Available: 2:nodejs-8.10.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.10.0-1nodesource
Available: 2:nodejs-8.11.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.11.0-1nodesource
Available: 2:nodejs-8.11.1-1nodesource.x86_64 (nodesource)
nodejs = 2:8.11.1-1nodesource
Available: 2:nodejs-8.11.2-1nodesource.x86_64 (nodesource)
nodejs = 2:8.11.2-1nodesource
Available: 2:nodejs-8.11.3-1nodesource.x86_64 (nodesource)
nodejs = 2:8.11.3-1nodesource
Available: 2:nodejs-8.11.4-1nodesource.x86_64 (nodesource)
nodejs = 2:8.11.4-1nodesource
Available: 2:nodejs-8.12.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.12.0-1nodesource
Available: 2:nodejs-8.13.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.13.0-1nodesource
Available: 2:nodejs-8.14.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.14.0-1nodesource
Available: 2:nodejs-8.14.1-1nodesource.x86_64 (nodesource)
nodejs = 2:8.14.1-1nodesource
Available: 2:nodejs-8.15.0-1nodesource.x86_64 (nodesource)
nodejs = 2:8.15.0-1nodesource

Last Update was second of february.
with

yum update --skip-broken

the update is running waiting for results …

more later …
mostly are okay but

Skipped (dependency problems):
nodejs.x86_64 2:8.15.1-1nodesource npm.x86_64 1:3.10.10-1.6.16.0.1.el7

any Idea?

thx Axel


(Markus Neuberger) #2

It seems you installed the nodesource repo, maybe due to onlyoffice install. This repo provides newer nodejs and npm versions that replace the epel packages which may lead to problems.

You may try to update with nodesource repo enabled:

yum update --enablerepo=nodesource

Or downgrade to epel version:

yum downgrade nodejs

Or if you don’t need newer nodejs versions, you may completely remove the nodesource repo and reinstall the default packages.

yum remove nodejs
rm /etc/yum.repos.d/nodesource-el7.repo
yum install nodejs

(Axel Urbanski) #3

hello Markus

yes i try Onlyoffice and netxcloud.
I try from the console

yum update --skip-broken

the result was

Skipped (dependency problems):
nodejs.x86_64 2:8.15.1-1nodesource npm.x86_64 1:3.10.10-1.6.16.0.1.el7

I want toinstall the Faxsever and IAX-Modem
so before i try the update from the softwarecenter again.
I was running fine an do the update

Mar 14 16:56:34 Updated: 1:nodejs-6.16.0-1.el7.x86_64 Mar 14 16:56:37 Updated: 1:npm-3.10.10-1.6.16.0.1.el7.x86_64

and the missmatch is gone

Onlyoffice and Nextcloud looking like thy are working (only a short test with a new doc)

If i find problems i will downgrade

thx Axel :slight_smile: