Hard drive bigger than 2TB, expand LVM


(Pascal Michard) #1

When I try to install neth in a VM with more than 2TB hard drive it doesn’t boot.
Need I to run the cent os install instead of the neth quick install to create some sort of boot partition or bios_grub?
It seems that when using the neth quick install it is not bootable from gpt?
Which bootloader is used (grub2)?


(Bogdan Costin) #2

It is recommended that you have a different boot partition (400MB or 1 GB).
This happened with CentOS also ?


(Pascal Michard) #3

Thank’s Bogdan.
I’m just trying it out.

What about kernel updates?
When using a boot partition with ubuntu the kernels stays in boot until they are deleted manually (autoremove).


(Bogdan Costin) #4

Yes you are correct, the same is valid here from what i know (this is why I recommend 1GB space for boot).

But this is valid for most distros. :smile:

Best regards
Bogdan


(Artem Fedai) #5

You should use GPT instead MBR :slight_smile: it is all about limitation of MBR


(Artem Fedai) #6

Anaconda (the graphical installer) starts, then press ctrl+alt+F2 to get a shell prompt. Create a new partition table on the blank drive:

parted /dev/sda
mklabel gpt
quit

Press ctrl+alt+F6 to return to the installer, Anaconda should recognize the drive at its full size and let you partition as normal.

Try it , i have no 2Tb storage…


(Pascal Michard) #7

actually gpt seems not to be the problem, booting from gpt is the problem. When using neth interactive install afaik it creats a gpt partition table. But after installation the VM doesn’t boot. I also tried to set VM mode to efi, but then I cannot boot from the ISO. Doesn’t the ISO support EFI mode?

I also added a second small virtual hard drive to install the system on it and wanted to mount the 2tb drive in /home. It worked but I just realized that neth isn’t using home and when using anaconda clear os without neth is installed.

Is there a possibility to choose the partitioning during installation of neth. As mentioned above, when installing ubuntu on a hard drive with gpt it is possible to boot to it by creating a bios_grub partition. I haven’t seen the possibility to creat bios_grub in anaconda.


(Pascal Michard) #8

I did some research:

  • Cent OS 6 still uses grub 1 which is not able to boot from GPT with a BIOS system
  • AFAIK it’s not possible to install grub 2 onto Cent OS 6 because of missing rpms

My conclusion:
AFAIK the only way is to create multiple virtual hard drives smaller than 2 TB with mbr and to join them in one LVM.
(As discribed by Jim: First(s) installs, few observations and help still needed)
If the Neth ISO is bootable from efi it would also be possible to switch to EFI mode, but as I read it is not recommended for VMs because it may create some incompatibilities, but maybe it’s better because multiple hard drives slows down the VM.

Edit:
To install neth in EFI mode:

  • Download Cent OS 6.6 minmal and install neth manually with yum
    (The Cent OS minimal Image is bootable in efi mode)
    http://mirror.nsc.liu.se/centos-store/centos/6.6/isos/x86_64/
  • configuring network during install process simplifies the process
  • an efi_boot partition is needed and if lvm is used a boot partition as well

Then there is no need to hassle with LVM extention as GPT can be used.


(Stéphane de Labrusse) #9

I use a smeserver 9.0 (centos6) over a HD of 4TB on an old P4HT (around 2005)

[root@backup ~]# parted /dev/sda print
Modèle: ATA WDC WD40EZRX-00S (scsi)
Disque /dev/sda : 4001GB
Taille des secteurs (logiques/physiques): 512B/4096B
Table de partitions : gpt

Numéro  Début   Fin     Taille  Système de fichiers  Nom  Fanions
 1      1049kB  263MB   262MB   ext4                      démarrage
 2      263MB   4001GB  4001GB                            lvm (gestionnaire de volumes logiques)

and my grub is

[root@backup ~]# rpm -qa grub
grub-0.97-93.el6.i686

However the HD came already partitioned in GPT, this is often the default when you buy a Huge HD.

I guess that if you do a GPT partition from another OS that should work.


(Pascal Michard) #10

Do you use a VM?
You have no EFI partition, so I expect that you are booting in BIOS mode.
I think it doesn’t matter wich OS creates GPT. I guess it depends on the BIOS.
Some BIOSes seems to support GPT. The Bios emulated from esxi seems not to support it.
Or maybe it depends on flags, then doing partitioning from another OS would indeed help.


(Pascal Michard) #11

After installing neth on cent minimum I get errors when installing modules from the software center:

Task completed with errors
S97nethserver-samba-sam-conf #384 (exit status 256)
Template /etc/httpd/conf/httpd.conf #125 (exit status 1)
expansion of /etc/httpd/conf/httpd.conf failed
Template /etc/postfix/mynetworks.cidr #164 (exit status 1)

There are others mainly with (exit status 1)

Any Ideas?


(Artem Fedai) #12

ESXI ? What version ? upgrade to 5.5 or higer to have a ability to use 2 TB space.
Try Gparted Live to make yuor disk GPT and create partition .
Try :
yum install yum-utils
yum update


(Pascal Michard) #13

it’s 5.5. So creating vdisk with more than 2 TB is possible.
As I installed from cent os minimum disk is GPT now and partitioned with lvm expect the boot and efi-boot.

I did
yum install yum-utils
yum update
and reboot
errors still there.


(Stéphane de Labrusse) #14

No a real computer just for BackupPC and a rsync of my movies

surely

Well, not sure that in 2005 the gpt partition was used, I would do a joke, send me the HD, I will test for you :stuck_out_tongue:

as I said, the HD came already partitioned from factory, it should be tested, but sometime VM can’t act as a real computer. From what I recall GPT can be used with Centos6, why not here.


(Pascal Michard) #15

:wink:

I have no clue.

I tried now another workaround:

  • reverted to bios added 20GB Drive
  • Installed Cent OS from neth ISO
  • installed bootloader and setup /boot partition on the 20GB drive
  • build LVM and combined the rest with the 3TB drive
  • successfully installed cent OS and neth afterwards

System boots up and the whole 3TB are recognized
But again I get the “Task completed with errors”

f.e. when installing mail:

Task completed with errors
S97nethserver-samba-sam-conf #96 (exit status 256)
Adjust service amavisd #46 (exit status 1)
restart service amavisd failed!
Template /etc/samba/smb.conf #67 (exit status 1)
expansion of /etc/samba/smb.conf failed
Adjust service amavisd #89 (exit status 1)
restart service amavisd failed!
Adjust service amavisd #100 (exit status 1)
failed
Template /etc/sysconfig/ipv4_services_custom #119 (exit status 1)
expansion of /etc/sysconfig/ipv4_services_custom failed

no error messages in yum.log

Does installer language matter? I chose german during Cent OS install.


(Artem Fedai) #16

Disable ipv6, it cause some trouble


(Pascal Michard) #17

Is it done by adding

#disable IPv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1

to /etc/sysctl.conf ?

I did so and rebooted but error persists.

Installing yum-utils shows following errors:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 294, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 229, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 586, in doTransaction
    resultobject = self.runTransaction(cb=cb)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1514, in runTransaction
    lastdbv = self.history.last()
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 1266, in last
    ret = self.old([], 1, complete_transactions_only)
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 1215, in old
    executeSQL(cur, sql, params)
  File "/usr/lib/python2.6/site-packages/yum/sqlutils.py", line 166, in executeSQLQmark
    return cursor.execute(query)
sqlite3.OperationalError: database is locked

Edit:

I also tried:

yum clean all
yum clean metadata

I read that a full disk or RAM can also cause the problem, but disk is not full and machine has 2GB RAM, so RAM shouldn’t be a problem.


(Artem Fedai) #18

show pls:
yum repolist

and make
rm -rf /var/cache/yum
yum clean all


(Pascal Michard) #19

gives me

Loading mirror speeds from cached hostfile
 * centos-base: centos.mirrors.psw.services
 * centos-updates: mirror.imt-systems.com
 * nethserver-base: nethserver.de-labrusse.fr
 * nethserver-updates: nethserver.de-labrusse.fr
Repo-ID                                     Repo-Name:                                      Status
centos-base                                 CentOS-6 Base                                   6.518
centos-updates                              CentOS-6 Updates                                1.370
nethserver-base                             NethServer 6.6 base                               327
nethserver-updates                          NethServer 6.6 updates                            273
repolist: 8.488

did it and yum update. Errors still persists.


(Artem Fedai) #20

show pls :

rpm -qa | grep python
rpm -Va python* yum*​
rpm --rebuilddb