Hanging during install

NethServer Version: nethserver-7.9.2009


Just downloaded the latest release and tried a fresh install ( Ryzen 7 ) via USB.

The installer hangs with the following error-

Kernel panic - not syncing - fatal exception
hpet1 lost 2 rtc interupts

I thought it may be a 32 vs 64bit issue but the iso is nethserver-7.9.2009-x86_64 so i assume that covers both architectures

Any ideas ?


Iso covers only x64, there’s no x86 architecture support for the ISO, AFAIK.
Issue seems related about access to RTC. And with some grub options, could be bypassed.

However, seems a kernel-related issue, so… maybe cannot be solved without an updated kernel.

which model/series of Ryzen 7? It could be an incompatibility with the CPU and CentOS 7.9.

Disabling some features (for instance, adding mce=off to the kernel boot options) or a more recent kernel could be needed (ELRepo’s kernel-ml…)

A better option could be to use some virtualitzation platform like proxmox instead of a bare-metal install. Here in the forum there is other people that can guide you better about it.

After some further investigation I think this is definately a kernel problem and I don’t see a way to resolve it with this version of Nethserver and 8.0 isn’t production ready yet so I’ll have to rey something else.

Thanks for the help - greatly appreciated.

You could still try with CENTOS 7 then neth-ify it. However, the issue might be the same.

Anyway: during boot phase you could still edit options and disable hpet via grub.