GRUB Problem after power failure

Hello friends!

I have a problem again!

In the last update there was a power failure and my NS is now stuck with GRUB.
Now I have only a minimalist GRUB system …

What can I do to get back a running system.

Many thanks for your help!!

Gerald

Easiest way is to restore a backup.
Otherwise boot the machine in rescue mode with a Centos or Nethserver DVD.
Enter the chroot and try to reinstall Grub and repair the yum transaction.

EDIT: I just changed the first sentence, thank you @m.traeumner for pointing out the mistake!

1 Like

Hello

mmmh, how do you say it works with the backup not quite …

I can see the partion in Grub Rescue mode but do not change anything.
I tried to start the system with the following entries:

    set prefix = (hd0,1)/boot/grub2
    set root = (hd0,1)

as

insmod linux
insmod normal
normal

to bring to life but unfortunately without success.

When I start with Rescue System from the Nethserver 7.5, I can mount and view and edit all partitions, but do not write a new configuration of grub2 …

Thus, no solution …

To chroot to your systems root and reinstall grub:

chroot /mnt/sysimage

/sbin/grub2-install /dev/sda

Here is a step-by-step guide:

https://www.tecmint.com/recover-or-rescue-corrupted-grub-boot-loader-in-centos-7/

3 Likes

I started with the ns7.5 image in the rescuesystem, but there is no grub2-install under sbin.

Is there a difference between the Image CentOS 7.5 and NS7.5 (except the add-on packages)?

You need to do step 5 - chroot first.

2 Likes

Thank you!

Now it works again, I had the instructions before but it did not work - because I had a broken image on the USB stick.

I have now taken another stick and downloaded a new image and everything worked immediately.

greetings
Gerald

2 Likes