Grow xfs filesystem

I have growed the partition of an additional disk mounted under ibay. How can I grow the xfs filesystem? I executed xfs_growfs -d /dev/sdb1 but under storage I stil see the 50 GB of the disk as unused.



See this:

Almost at the bottom…

My 2 cents

Hi Andy, thanks.

Thats what I already did (without the lvm part as I dont use it). The new disksize is apparently recognized as I have 50 GB unused space when I look under system/massstorage. But the xfs_growfs seems to be ignored. Maybe its just a matter of reboot, but I doubt it and I can’t do it now that its being worked on.

You’re not using LVM in NethServer?
That is standard, you know… :slight_smile:


I know, but I dont need it, it’s just a useless layer in our usecase :slight_smile:

Well, disk enlargement would have worked with LVM… :slight_smile:

-> Not quite useless! :slight_smile:

My 2 cents

It would had been just a step more inbetween, I would have had to grow the vg/lv. Disk enlargement worked fine, else I would not see 50 GB (the amount I enlarged the disk) under system / masstorage as unused space. It’s just the filesystem grow that is not apearing (yet). The filesystem normaly doesn’t care if it’s a lvm volume a raid or just a partition underneath. Maybe its just not updated because it is a mounted partition. I’ll check later.

Does a reboot help?

Stupid me. I had used cfdisk to grow partition, and did not pay attention to its message while quitting; it actually did not resize it. Done it with fdisk now, then xfs_grow. All good :slight_smile:

1 Like