Glpi error on cost management for decimals

Hello everyone, I use glpi v 10 and I wanted to ask why in the cost management of a peripheral, if I try to enter the price eg. 10.40 euro the system proposes error as it obliges 4 decimal places. In my configuration there are 2 decimals, but it makes no difference.

“importo” means something close to “price”
“Inserisci un valore valido” means “Insert a valid value”.

@france I am Italian, as most of developers of NethServer are. However, the forum language is english and for a reason.
Please, consider to post english messages.

Rolling back to the problem.
After changing 4 decimal digits after . to 2 decimal digits, did you logoff and logon again?
Last but not least: your screenshot show a , for separate between units and decimal. Which is your separator character ? . or , ?

Hi, sorry. I changed.

Yes, I tried to log out, but nothing. Also from the new attachments the error is reported in Italian (perhaps cache) the rest in English.
The separator is “,”

Trying to access in “incognito”/anonymous/in private with your preferred browsers, change something?
Did you look for this kind of issue into GLPI support documentation/support/community?

Hi, I tried Opera and Firefox and Safari. On GLPI forums not yet -

So… Blink, Gecko and Webkit.

The answer from the forum as well as from a developer (at least I think).There have been hundreds of patches since 10.0.0. Please update to 10.0.3 to see if this is a bug that was already fixed.

1 Like

paging @stephdl for letting know the issue :wink:

1 Like

I think i offered 10.0.2 with nethserver-glpi-10-latest

Ok, thank you. So do you assume the problem is elsewhere or do you plan to do 10.3? If I got it right …

@france you could also check the bugllist of GLPI.

I don’t understand what you’re indent, probably the google translation …

Yes i will try to update. I have something more related to timezone ???

I don’t use google translator…
I’m meaning that probably the bug is originated into GLPI and maybe you can check the buglist of GLPI 10 or the release notes, for finding the same issue and in which version/component has been solved.

Thanks for your time, @stephdl

I will certainly do the research you are asking for. Unfortunately, unlike you, I have to use it … :monkey:

Thank you as usual.

I’m not telling you “do this!”
I’m suggesting a way for understand if the current version (according to stephdl should be 10.0.2) should already have the bug patched or if there’s something else that should be tuned.

Yes, I understood, I’m sorry you misunderstood. I understood that I could see if I could find any other useful information. Nothing of a do. However, I know that several users on the forum use glpi and at the moment I have raised the problem. Probably someone makes little use of costs … Anyway, thank you for your intervention.

10.0.3 released as nethserver-glpi-10-latest-1.0.11-1.ns7.noarch.rpm


Ready for an update, @france ? :wink: Don’t forget to clear browser cache or access the first time, after the update, into an “incognito” web browser.