Glpi-10 needs testers

In few hours, once some changes are propagated to my mirrors, we could test glpi10 stable

Install my repository then

yum install https://mirror.de-labrusse.fr/NethDev/nethserver-glpi-latest/nethserver-glpi-latest-1.0.8-1.ns7.sdl.noarch.rpm https://mirror.de-labrusse.fr/NethDev/nethserver-glpi-latest/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch.rpm

  • test upgrade from 9.5
  • test first install
4 Likes

Morning @stephdl

on a fresh installation, i am getting the following error:

--> Finished Dependency Resolution
Error: Package: nethserver-glpi-latest-1.0.8-1.ns7.sdl.noarch (/nethserver-glpi-latest-1.0.8-1.ns7.sdl.noarch)
           Requires: php81-php-xmlrpc
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-ldap
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-mysqlnd
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-imap
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-mbstring
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-fpm
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-intl
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-xml
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-gd
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-pecl-zip
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-soap
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-pdo
Error: Package: nethserver-glpi-latest-1.0.8-1.ns7.sdl.noarch (/nethserver-glpi-latest-1.0.8-1.ns7.sdl.noarch)
           Requires: php81-php-sodium
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-bcmath
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-enchant
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-process
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-pgsql
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-opcache
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-pecl-apcu
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: php81-php-tidy
Error: Package: nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch (/nethserver-remi-php81-php-fpm-1.0.1-1.ns7.sdl.noarch)
           Requires: remi-release
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Sorry @oneitonitram you must install my repository first

ah, i see. sorry. i had assumed the server has your repo(or maybe that it wasn’t required)

1 Like

Upgrade from glpi10 RC3 workd with no issues. All modules were disabled, required enabling and updating.

Fresh installation worked well. no issues, no problems.

2 Likes

Update from nethserver-glpi-latest 9.5.7 to 10.0.0 worked without issues. Assets and documents are still there.

2 Likes

Yes I added it after, in fact I pushed all dependencies needed to PHP81 from remi-safe on my repo. Obviously I missed to write to add my repo first

1 Like

released

2 Likes