FTP Access and Vsftpd user_list

I have an special fanstastic ricoh aficio mp c2003 in my company.

when try to Scan to SMB folder authentication failed on DC.

My Printer support say “this model dont support samba 4”

ok! i use FTP auth on printer.

i follow this http://docs.nethserver.org/it/v7/ftp.html

config setprop vsftpd UserType system
signal-event nethserver-vsftpd-save

db accounts setprop goofy FTPAccess enabled
signal-event user-modify goofy
signal-event nethserver-vsftpd-save

but i think missing adding goofy to > /etc/vsftpd/user_list
same for > /etc/vsftpd/chroot_list

1 Like

For no italian speaking people use this link:

http://docs.nethserver.org/en/v7/ftp.html

I don’t think so, the code is inside both templates:


Please check the accounts db has the user record:

db accounts show

Also bear in mind that the setprop sub-command doesn’t create the record. You probably need to create the record:

db accounts set goofy user FTPAccess enabled

FatturePassive=ibay
AclRead=enzo@xxxxx.it
AclWrite=enzo@xxxxx.it
Description=Fatture Passive
GroupAccess=rw
OtherAccess=
OwningGroup=amministrazione@xxxxx.it
SmbAuditStatus=enabled
SmbGuestAccessType=none
SmbRecycleBinStatus=enabled
SmbRecycleBinVersionsStatus=enabled
SmbShareBrowseable=enabled

I did this

Did you solve it?

Sorry,
I had already done that operation, but the chroot file is empty. Only inserting my accout directly with nano works

Users are chrooted only if the FTPChroot option is enabled:

db accounts set enzo@xxxxx.it user FTPAccess enabled FTPChroot enabled

See the manual (at the end of the page: http://docs.nethserver.org/en/v7/ftp.html) and the code (https://github.com/NethServer/nethserver-vsftpd/blob/master/root/etc/e-smith/templates/etc/vsftpd/chroot_list/10users#L25).

I am trying to follow this process. I have a Toshiba eStudio-165 that also does not support Samba 4. The only two options are FTP or SMB for scanning.

I tried to set up FTP as in the directions here. I got this from above.

The Nethserver is a domain controller with domain domistyle.ad.

Here is what I did:

config setprop vsftpd UserType system
signal-event nethserver-vsftpd-save
db accounts set ftpuser@domistyle.ad user FTPAccess enabled FTPChroot enabled
signal-event user-modify ftpuser@domistyle.ad
signal-event nethserver-vsftpd-save

I used db accounts show to see if the config was set and it appears to be.

When I tried to log in via a command line ftp client (whatever is in Ubuntu 16.04 or 17.10), I get the following:

kyle@homesrv2:~$ ftp neth
Connected to neth.domistyle.ad.
220 (vsFTPd 3.0.2)
Name (neth:kyle): ftpuser@domistyle.ad
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp> quit
221 Goodbye.

I typed out the password and cut and pasted it so I know that it is correct.

The chroot list is still empty. The user list has "ftpuser@domistyle.ad" in it. Is that correct behavior?

I also am not sure I can even enter the “@” character on the keyboard on the Toshiba eStudio 165. Is there a way to change the user to be just “ftpuser”?

Any pointers to how I might debug this would be helpful.

Another point: does this allow for writable roots in the chroot? According to some Arch documentation I found, here, vsftpd will prevent any write to the root of the chroot. If you are sharing a single directory for things like scans, this is a problem. The Toshiba eStudio 165 is not able to have a path set beyond just a single directory (at least as far as I can tell).

The vsftpd config variable that controls this is allow_writeable_chroot=YES.