From an older toy, to an old toy

Older toy
image
Linkstation LS-WXL
CPU Type Marvell 88F5182 ARM
CPU Speed 600MHz
RAM DDR2 128MB
Drive Interface SATA 1, 1.5Gb/s

Old toy
image

Synology DS212j
CPU MARVELL Kirkwood 88F6281 @ 1.2GHz•
Memory: 256MB DDR2 400
Internal HDD: 2X 3.5” SATA(II) or 2X 2.5” SATA/SSD•
Max Internal Capacity: 6TB (2X 3TB hard drives) (hard drives not included)•

Not suggesting anyone to buy/use this kind of hardware as standard.
But IMVHO this… seem an upgrade to me.

Hi

The Synology DS212 can actually handle 4 TB Disks, eg WD Red Plus…
(But not 6 TB disks!)

My 2 cents
Andy

Which part of “j” did you missed at the end of the model? :wink:

Yes, it was a “j”, a client bought that before my time, it was operational until end of 2021.
It’s still working, but now shut down and no more used…

After 10 years, it’s earned it’s pension!

:slight_smile:

Any disk operation, the CPU went up to 100%…

As old toy (nicknamed Zombie) does currently.
CPU occupation with 1,5Mbyte/s transfer rate (back/forth on 802.11n adapter, and zyxel USG20W subnet)
Old 320GB 2,5" hitachi drive as test install.
image

I’m not gonna format a 2tb XFS RAID1 drive without tests.

Really like Synology, they just keep on working with little fuss and issues!

However, have you played with Xpenology: https://xpenology.org/#What_is_Xpenology

Works well and is worth a look.

Klaus

@KdB

Hi Klaus

I have a copy of Xpenology running on Proxmox. Works well, except for system updates…
Application updates seem to work, hardly any issues here. System updates / upgrades are a different animal / issue, as can be expected.

A smaller issue is the missing QEMU Agent, but that is not really a big problem.

My 2 cents
Andy

I can’t find much about the vendor, what amount of trust would you have with them?

@royceb

Hi Royce

R U refering to Xpenology?

My 2 cents
Andy

Correct. I’ve read about Xpenology being DSM with a specialized bootloader but haven’t dived deep into the subject.

XPenology is a third-party, open-source bootloader for DSM.

Well, I’ve been playing around with Xpenology for a while.

Due to the fact that none of my “older” hardware lying around would suffice to run Xpenology (CPU to low to emulate a real Synology…) AND generally the fact that you need more or less “matching” hardware to a real Synology to be able to use it, you’re kinda limited for testing on older hardware.

What does work is using a Proxmox emulation…

Only certain CPU types will work, also Intel NICs will work (Not a VirtIO NIC!), but it’s possible to get it to work.

It looks and feels exactly like a Synology hardware once it’s up and running. Most Synology Apps can be installed and do work correctly, even updating the Apps work.

What does NOT work is updating the System itself - as that would entail using a different (newer) Bootloader. So basically once it’s up and running, it’s almost always on an “older” system.

The Qemu Guest Agent can’t be installed, entailing caveats when shutting down the system. From the Synology Web-GUI (DSM) shutting down works well.

It’s usable, suitable also eg for testing or learning. But don’t expect the ease of use as with a real Synology, especially with the often appearing updates for the System.

Using Proxmox, it makes more sense to let the Hypervisor (Proxmox) handle Disk RAIDing and also NIC Bonding, although Xpenology can handle BONDING well enough.

I need to use a boot image, a disk image (system of DSM) and a third Disk for Data storage.
I also need to use two NICs, one as placebo, one actually used.

My 2 cents
Andy

Synology, like Apple, does NOT allow DSM to be installed on any foreign (non-Synology) hardware, so the fact that the Bootloader is open source is kinda moot, as the DSM is not legal to use on non Synology hardware…

Apple does allow their MacOS to be virtualized, when running on Apple hardware, and Proxmox installs easily eg on a Mac Mini (At least on the Intel based ones, never tried with an M1 chip).

Synology, like NethServer, can also run KVM, Synology even offers a “Virtualzation KVM App” which runs on stronger hardware of Synology. This would make Xpenology kind of “legal”…
In a Synology based KVM environment, the bootloader is not even needed, as DSM will run here directly.

My 2 cents
Andy

1 Like

Back to topic…
Using rsync was not an option. First tests gave me not more than 2.5Mbyte/s.
So now I’m trying a more “tinkered” solution:

  • Remove 2nd drive from the Linkstation
  • Repurpose the DS212j from “Zombie” (2x500gb WD Blue laptop drives… with crappy Trim support) to “Undead” (1x2tb WD Red drive)
  • Created all the shares already available on the linkstation
  • connected a boot drive (32bit linux installation with XFS support), 1x2tb drive from linkstation (XFS mdadm RAID), 1x2tb drive from synology (Ext4 SHR RAID)
  • mount the data partition from both drives
  • and mc powerchord (multiple simultaneus executions) for copying data from XFS to ext4

Hoping everything goes as expected… cumulative transfer rate close to 55-60 Mbyte/s.
Next scheduled steps.

  • gracefully shutdown the linux installation
  • connect right drive to Undead (drives were marked… always mark your drives before connecting to some other places)
  • boot up
  • finger crossed

Since there, a long of iterative ifs list.

Update. Good news, and bad ones.
First of all, data copy went beautifully wrong. The destination folder was wrong, but data has been copied.

If you’re browsing into filesystem of a detached hard drive from Synology SHR, if you find a tempting @eaDir/sharename that’s not the directory you’re looking for. I know by sure because every file was copied from the XFS drive has been put there.
The “right” path should be /volume1/sharename. I found the same path during my tinkered wanna-transfers, but i was not able to write to that directory. Shame on me, now i’m looking for a way (SynoCli Tools) to use mc on the Undead DS212j. Hoping that mv won’t take that long…

Yes, you’re right, I don’t know how to correctly use mv from SSH. Better safe than sorry the second time…

(and mc worked like a charm…)