Freepbx: Module "Core" signed by an invalid key


I recently updated Nethserver and now have an error in Freepbx. The Dashboard reports:

freepbx problem

Module “Core” signed by an invalid key.
Module: “Core”, File: “module.sig check failed! Signed by unknown, untrusted key.”

I have tried:

fwconsole ma refreshsignatures
fwconsole chown

as recommended in other posts but this does not solve the problem.

Can anyone help?


NethServer Version: 7.7.1908
Module: Freepbx

I couldn’t reproduce.

You may try

fwconsole ma downloadinstall core

to redownload the core module.

You can try to update FreePBX modules from command line:
scl enable rh-php56 -- fwconsole ma updateall

Thank you mrmarkuz and fausp. I have tried both of your suggestions but it hasn’t fixed the problem unfortunately.

In this case you may try to disable the core before reinstall. It should work but it’s always good to have a backup/snapshot.

  • Disable modules depending on core
  • Disable core - if it does not work check the error message, you may need to disable more modules
  • Download core from upstream and install
  • Enable modules
  • Adjust permissions

On a fresh installed freepbx it worked like this:

fwconsole ma disable callrecording cdr featurecodeadmin sipsettings userman voicemail
fwconsole ma disable core
fwconsole ma downloadinstall core
fwconsole ma enable core
fwconsole ma enable callrecording cdr featurecodeadmin sipsettings userman voicemail
fwconsole chown

If this does not work uninstalling instead of disabling core would be a possibility but it drops database tables so please backup.
If you do it you’ll need a

signal-event nethserver-freepbx-update

to reconfigure PBX for Nethserver (LDAP users etc.).
I didn’t test that and don’t know if it’s possible to reimport the database afterwards but it’s worth a try in last instance.

Thanks for all your suggestions, it’s working now!

1 Like