FreePBX - "Can Not Connect To Asterisk"

NethServer release 7.9.2009 (final)

After the install I got a error in NethServer Cockpit that told me I need to run the following script in terminal -

echo ‘{“action”:“remove”,“packages”:[“nethserver-freepbx”]}’ | /usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update | jq

So I did and got the following -

I went into the FreePBX gui and was greeted with the following (I noticed I was not able to login) -

I trying login to FreePBX.

I tried to follow some of the items I have seen in Nethserver community such as -

but it only update it and didn’t clear the “Can Not Connect To Asterisk”, I still was not able to login… as the "Can Not Connect…: eludes too.

I also noticed that shown below in picture the Web interface access is not pointing to the correct ip -

I change the ip address to what it should be, but it did not make a difference in clearing the “Can Not Connect To Asterisk” message on Web Interface.

I also noticed I got the following error in terminal shown below when trying to change the Web Gui password -

Anyone know what I should do here?


1 Like

@Shadowfire, is this a completely new deployment instance of FreePBX on NS7 you are working on.

IF this is the case, Couldn’t you wait a little longer for Nethvoice on NS8, whih i beeive has more tighter integrations, and considering NS7 would soon be EOL, wouldnt it be wise to have this setup on NS8 instead.

if its an old eisting deployment its fine, but for a new Deployment wouldnt make sense in my view, considering the new VErsion should be around the conner, maybe in a month(not sure)

Keep track here: Global board · NethVoice NS8 (

@Amygos might be better placed to provide some timeline

1 Like


I appreciate the follow up and recommendation to NS8. The server I am working with is my personal existing business server. At some point I will move forward with NS8. Just not at this time. I am watching the forums - for me it is not as mature for my taste in getting knee high in migration woes, especially when I see a lot of challenges on the forums from NS8 migrations at this time.

My NS7 is running smoothly. I just want to add FreePBX to the existing mix. Hope this gives you insight in to my thoughts.



echo ‘{“action”:“remove”,“packages”:[“nethserver-freepbx”]}’ | /usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update | jq

I’m afraid you removed nethserver-freepbx package, maybe try reinstalling it again

1 Like

I did reinstall it. But still getting the “Can Not Connect To Asterisk” message on Web Interface.

So I did a asterisk -r and got the following -

and still getting this -

I am guessing the “Can not connect to Asterisk” is due to the "NOTICE[18178]: manager.c:3681 authenticate: failed to authenticate as ‘admin’ "

I am still digging to find the answer.


I found that some people where having success with permissions by doing “fwconsole chown” command, but this is what I got when I put that in…,.

use scl enable rh-php56 -- before fwconsole commands, freepbx runs on another php version:
scl enable rh-php56 -- fwconsole chown

But this command doesn’t fix yor problem, you have to check the manager admin secret inside /etc/asterisk/manager.conf and make sure is the same inside /etc/amportal.conf
and in FreePBX mysql
mysql asterisk -e "SELECT value FROM freepbx_settings where keyword = 'AMPMGRPASS' "


@Stll0 This is exactly what was needed. I went back and looked at the /etc/asterisk/manager.conf, /etc/amportal.conf and mysql asterisk -e "SELECT value FROM freepbx_settings where keyword = 'AMPMGRPASS' "

I found that the and mysql freepbx_settings had the same password. I had to go in to /etc/asterisk/manager.conf` and change the secret = XXXXXXXXXXXXXX as shown below.

secret = XXXXXXXXXXXXXX <---- (change this to be the same)
read = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate,message
write = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate,message
writetimeout = 5000

Thanks for helping me getting past the “Can Not Connect To Asterisk” message on Web Interface.

Okay. That worked… no more “Can Not Connect To Asterisk” message on Web Interface. Very nice…