Force SSL only on Webtop?


(Bobby Dilton) #1

Hi,

I’m trying to force the URL to stay on https when accessing the Webtop, but once I logg in, the URL changes to HTTP, I need to rewrite it to HTTPS to make it continue.

Under preferences, I’ve changed the Public URL to HTTPS, but it still changes.
Any ideas?

Best regards


(Markus Neuberger) #2

It is rewritten to HTTPS by default so no need to change anything in the Webtop settings.

In /etc/httpd/conf.d/default-virtualhost.inc you should find the following rewrite rule:

#
# 20webtop
#
RewriteEngine on
RewriteRule ^/webtop(/.*)?$ https://%{SERVER_NAME}/webtop$1 [L,R=301]