First run wizard failure

installprocedure
v7

(David Gordon) #1

System version
NethServer release 7.5.1804 (final)
Kernel release
3.10.0-862.el7.x86_64

I’m installing Nethserver on a Mac using Virtual Box and following along the YouTube video https://www.youtube.com/watch?time_continue=4&v=kggkwioK-ls&app=desktop

So far so good but when I try and complete the first run wizard it times out saying the page has expired. I reload and try again but the same happens. I can go direct to 192.168.0.100:980 and see the NS Dashboard.

This is my second attempt at a NS install and I noticed the same last time. (Then I followed a ‘how to’ from these forums but it seems a little out of date now.)

Anyhow, something I’m doing wrong or something else?

As far as I know the only thing I’m not completing using the wizard is the change of SSH port. But I’m sure the wizard will want to run again if I reboot…


(Rob Bosch) #2

could this be the known problem with anaconda installer: IP 192.168.1.1 after the installation ?

What happens if you use unattended install? NS will get an IP through DHCP and you can change that after you finished the initial wizard and log into webinterface.


(Stéphane de Labrusse) #3

open the vm in a window, login with root and your password, then issue ip addr and check what IP you use

192.168.1.1 is a failback address if the server cannot use the IP you set, or cannot get an IP from dhcp


(Marc) #4

There’s a session timeout feature, but shouldn’t have come into play for such short time period.

The first config wizard runs the first time but maybe got interrupted somehow. It can be recalled using its URL.

Maybe /var/log/messages tells us what happened


(David Gordon) #5

Yes, that reports the correct IP address I expect.

Indeed, when I restart NS I get the wizard again. But I also get the same result and can’t complete it. I’ve looked through that log and nothing jumps out at me. But then again I’m not sure what I’m looking for!

Thanks.


(Marc) #6

It happens at the last step, when pushing the button to confirm all the changes? Does it happen using another web browser?
Can you post an excerpt of the log (within the timeframe it failed)?


(David Gordon) #7

No, I don’t get that far. I think the first option is to ‘restore configuration’. I don’t check the box to do that, and click ‘next’. That’s when I get the error message, “The page has expired”. SO I can’t move to the next section (‘set host name’) or get all the way to the end.

I’ll try another browser and see, later.

Thanks again.


(David Gordon) #8

Sorry about my bad quote formatting!


(Dan) #9

Did you find anything? I’m running into the same problem. I installed Neth on top of a clean, up-to-date CentOS 7.5 installation (instructions here) on a new VPS. It’s using the correct IP address; I can reach it via SSH and the server manager at that address. But the First Configuration Wizard is dying at the first step with the same error: “The request cannot be completed because this page has expired.”

Edit: Well, I can get out of the wizard by clicking the Neth logo in the upper left–I guess that’s good enough; I can set what I need to manually.


(David Gordon) #10

I don’t know what I did or if there was a new release meantime but I’ve installed a couple of new Nethservers since my first post and the wizard has run correctly on each occasion. I’m sorry that doesn’t help much…