Fax reports not in english


(hany) #1

whenever i receive fax reports , they are in Italian
how to receive English reports


(Giacomo Sanchietti) #2

It’s not well documented :expressionless:, try this commands:

config setprop hylafax Lang en_US
signal-event nethserver-hylafax-update

You can find more info here: http://docs.nethserver.org/projects/nethserver-devel/en/latest/hylafax.html


(Artem Fedai) #3

Hi @hany and @giacomo , according to hylafax dictionary :

 less /var/spool/hylafax/bin/dictionary

if you do not specify Lang it will be English by default.

So @hany try

config setprop hylafax Lang ' '
signal-event nethserver-hylafax-update

(Alessio Fattorini) #4

IMHO it should be the default


(Giacomo Sanchietti) #5

You’re right, fixed in v7: https://github.com/NethServer/nethserver-hylafax/commit/727b405cd2cac13dd0c31e50dd52eb1dd5915bc8


(Stefano) #6

do you mean that only in NS7 it will be corrected?

you’d correct it in 6.X branch too… people will use it for a quite long time, you can’t expect them to poke with CLI for such things


(Filippo Carletti) #7

No, fixes will be backported when we close 7a2.


(Giacomo Sanchietti) #8

Usually, changes to default configuration should be integrated only when there is a new major version like 7 (or 6.8).
But I agree with you that this is should be consider a bug.

Can you please open a new issue, cherry-pick the commit and open a pull request?
Thank you! :smile:


(Artem Fedai) #9

@alefattorini @giacomo ,

I reinstalled fax server :

Lang=it_IT

is hard coded

Maybe we need the Menu for Languages in feature releases?


(hany) #10

even with the webmail client roundcube , when the user login for the first time it’s all Italian
he has to guess where is the settings “in Italian” and then “languages” and changes it back to English
but don’t expect all users to be able to do that right a way


(Artem Fedai) #11

Oh @hany

please run

yum install nethserver-lang-en

or form

Administration => Software Center install English support.


(Giacomo Sanchietti) #12

No is not, it’s a prop and it’s inside the db.

Absolutely!


(Giacomo Sanchietti) #13

Roundcube will use the default language of you browser (see https://github.com/NethServer/nethserver-roundcubemail/blob/master/root/etc/e-smith/templates/etc/roundcubemail/config.inc.php/60USER_INTERFACE#L18) , but you can also change it from Settings page.