Failure to request new Server Certificate

NethServer Version: 7.4
Module: Server Certificate

When I try to request a new Let’s Encrypt Certificate, I receive the following error:

Domains_ _Traceback (most recent call last): File "/usr/bin/certbot", line 9, in <module> load_entry_point('certbot==0.31.0', 'console_scripts', 'certbot')() File "/usr/lib/python2.7/site-packages/", line 378, in load_entry_point return get_distribution(dist).load_entry_point(group, name) File "/usr/lib/python2.7/site-packages/", line 2566, in load_entry_point return ep.load() File "/usr/lib/python2.7/site-packages/", line 2260, in load entry = __import__(self.module_name, globals(),globals(), ['__name__']) File "/usr/lib/python2.7/site-packages/certbot/", line 21, in <module> from certbot import client File "/usr/lib/python2.7/site-packages/certbot/", line 16, in <module> from acme import client as acme_client File "/usr/lib/python2.7/site-packages/acme/", line 37, in <module> requests.packages.urllib3.contrib.pyopenssl.inject_into_urllib3() # type: ignore File "/root/.local/lib/python2.7/site-packages/urllib3/contrib/", line 118, in inject_into_urllib3 _validate_dependencies_met() File "/root/.local/lib/python2.7/site-packages/urllib3/contrib/", line 153, in _validate_dependencies_met raise ImportError("'pyOpenSSL' module missing required functionality. " ImportError: 'pyOpenSSL' module missing required functionality. Try upgrading to v0.14 or newer.

The email address I use is the same as I have always used and the server in question does email me on that email address.

The Domains in the list is the FQDN domain in the list and I use it to connect to the server so I know its valid.

Not sure what I am missing here, other than certain software upgrades which have occured which has broken this functionality?

Could you try these commands?

yum --enablerepo=nethserver-testing install nethserver-base nethserver-httpd nethserver-letsencrypt
config setprop pki LetsEncrypt enabled
[root@server ~]# yum --enablerepo=nethserver-testing install nethserver-base nethserver-httpd nethserver-letsencrypt
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
 * ce-base:
 * ce-extras:
 * ce-sclo-rh:
 * ce-sclo-sclo:
 * ce-updates:
 * epel:
 * nethforge:
 * nethserver-base:
 * nethserver-updates:
nethserver-testing/7/x86_64/signature                                                                                                  |  
836 B  00:00:00     
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-NethServer-7
Importing GPG key 0x39BAF5C1:
 Userid     : "NethServer 7 (NethServer 7 Official Signing Key) <>"
 Fingerprint: 594c 3fd8 fae1 8ff5 32fe ae23 9cb2 8ea0 39ba f5c1
 Package    : nethserver-release-7-13.ns7.noarch (@nethserver-updates)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-NethServer-7
Is this ok [y/N]: y
nethserver-testing/7/x86_64/signature                                                                                                  | 
2.9 kB  00:00:02 !!! 
| 137 kB  00:00:00     
Package nethserver-base-3.7.2-1.ns7.noarch already installed and latest version
Package nethserver-httpd-3.2.7-1.ns7.noarch already installed and latest version
Package nethserver-letsencrypt-1.1.6-1.ns7.noarch already installed and latest version
Nothing to do
[root@server ~]# config setprop pki LetsEncrypt enabled

When I then try to request a new certificate, I still get the same error.

Did you use pip in the past to install some python module?
The outcome of this command might lead to more clues:

python -c 'import certbot, requests, urllib3, OpenSSL; print("certbot :", certbot.__version__); print("requests: ", requests.__version__); print("urllib3 :", urllib3.__version__); print("OpenSSL :", OpenSSL.__version__)'

The error looks similar to this, which suggest to use pip to remove some packages and yum to reinstall the correct ones (but, when using pip, take care on what is removed as it can create a mess).
Other similar issues

Yup! That first link helped to provide the solution @dnutan.

Thanks for the help!

I can’t remember what pip stuff I installed in the past 2.5 months which does not help