Failed to Migrate from 7 to 8

NethServer Version: 7.9 to 8 migration
Module: Nethserver 7 to 8 migration
Hello everyone.

I’m trying to install the nethserver migration to 8 update and ran into some issues.
On my 7 server it wouldn’t install as it complained about missing wireguard-tools. I ended up installing the rpm manually from file and that seemed to allow the install. So just a note I guess (none of the repos seemed to have it)?

Then once installed I then connected my nethserver 8 system to the MS AD ldap server in house. That worked and it failed to list domain users and got this error. The connection works because it does pull the list of groups correctly.

Traceback (most recent call last):
  File "/var/lib/nethserver/cluster/actions/list-domain-users/50list_users", line 33, in <module>
    users = Ldapclient.factory(**domain).list_users()
  File "/usr/local/agent/pypkg/agent/ldapclient/", line 127, in list_users
    "locked": bool(entry['attributes']['userAccountControl'] & 0x2), # ACCOUNTDISABLE
TypeError: unsupported operand type(s) for &: 'list' and 'int'

I tried to migrate from the 7 to 8 (using the migrate application on 7) but it just spins. and when I look at the nethserver 8 console it installs mail but never configures anything. When I connect to the mail application in the 8 console it starts the setup process prompting me for the primary domain for mail. If I run through that and start the mail domain setup I end up with another error.

<7>systemctl --user enable --now clamav.service
Created symlink /home/mail4/.config/systemd/user/ → /home/mail4/.config/systemd/user/clamav.service.
Created symlink /home/mail4/.config/systemd/user/ → /home/mail4/.config/systemd/user/dovecot.service.
Created symlink /home/mail4/.config/systemd/user/ → /home/mail4/.config/systemd/user/postfix.service.
Created symlink /home/mail4/.config/systemd/user/ → /home/mail4/.config/systemd/user/rspamd.service.
Created symlink /home/mail4/.config/systemd/user/ → /home/mail4/.config/systemd/user/clamav-unofficial-sigs.timer.
Traceback (most recent call last):
  File "/home/mail4/.config/actions/configure-module/90mail_domain", line 32, in <module>
    mail.doveadm_query("mailboxCreate", {"mailbox": ["postmaster"], "user": "vmail"})
  File "/home/mail4/.config/pypkg/", line 271, in doveadm_query
    raise DoveadmError(oresp)
mail.DoveadmError: [['error', {'type': 'exitCode', 'exitCode': 75}, 'mailboxCreate']]

I assume the issues are related.

Does anyone have some advice where to start?
Thank you

the mail migration seems broken, we need to investigate why

Is there anything I can provide to assist?

1 Like

Hi, may be the source of the two problems
similar (we have problem with mailboxCreate too):